⑤ error: Chrome version must be >= 55.0.2883.0

一、error问题:

当测试应用内有webView页面时,需要切换到上下文,交由Chrome Driver执行命令,这时由于手机系统的Android system webView和appium的 /appium/node_modules/appium-chromedriver/chromedriver/ 版本不一致,可能会出现问题!

查看手机Android System WebView版本号

设置>应用程序管理>全部,查找到Android System WebView应用,查看详情,显示版本号

二、Chromedriver与手机Android System WebView对应关系

http://www.cnblogs.com/testervic/p/6705159.html

下载对应版本的chromeDriver,替换更新即可解决问题!


如果条件允许,可更好不同版本的手机做测试,本人更换了与chromeDriver对应版本的手机后,没再报错!

推荐阅读更多精彩内容