Cocoapods连接失败错误,快速安装Cocoapods

字数 759阅读 333

pod拒绝连接 遇到如下错误:

错误描述 :
[!] /usr/bin/git clone https://github.com/CocoaPods/Specs.git master --progress

Cloning into 'master'...
fatal: unable to access 'https://github.com/CocoaPods/Specs.git/': Failed to connect to 127.0.0.1 port 1080: Connection refused

第一☝️:

查询是否使用代理: git config --global http.proxy
取消掉代理: git config --global --unset http.proxy

结果我发现不管用,

第二☝️:

  1. 查看你的git配置
    终端输入: git config --global -l
    下面👇就是说的问题咯,

If you have nothing related to https proxy like https_proxy=... the problem is not here.

If you have something related to https proxy then remove it from the file ~/.gitconfig and try again

就是说如果没有使用代理,那可能问题不在代理这里,删除 ~/.gitconfig 这个文件。
(如果没显示快捷键 command+shift+. 显示点开头的隐藏文件)

注意⚠️:这个解决办法是删除pod的配置和设置,我没有找到好的办法所以重新删除了,再重新安装一下pod。

首先进入 ~/.gitconfig 这个文件夹,我直接把这个文件夹里面的设置都删除。,,,参考了这篇

<>如何快速安装Cocoapods

Cocoapods来回下载好多次,下载超级慢,试了好多次都是下载失败,后来看到这篇里面就自己补充写下来了。

先删除干净pod残余

sudo gem uninstall cocoapods

再删除安装过的cocopods相关东西,执行

gem list --local | grep cocoapods

显示如下:
cocoapods (1.0.1)
cocoapods-core (1.0.1)
cocoapods-deintegrate (1.0.1)
cocoapods-downloader (1.1.1)
cocoapods-plugins (1.0.0)
cocoapods-search (1.0.0)
cocoapods-stats (1.0.0)
cocoapods-trunk (1.0.0)
cocoapods-try (1.1.0)

如果出现上述列 使用命令逐个删除,
使用终端输入 sudo gem uninstall 加上 👆列表显示的内容

例如:
sudo gem uninstall cocoapods
sudo gem uninstall cocoapods-core
sudo gem uninstall cocoapods-deintegrate
......等等

然后继续执行一下

sudo rm -rf ~/.cocoa-pod

再执行:

pod repo remove master

//然后执行替换成下面这个索引库的镜像

pod repo add master https://gitcafe.com/akuandev/Specs.git

(此时打开 ~/.cocoapods/repos 这个文件之后,看看里面有 master 文件夹没有,没有就手动创建一个,有时候需要,有时候不需要,(如果提示文件已经存在,那么就删除master这个文件夹,继续执行))

继续执行

git clone https://git.coding.net/CocoaPods/Specs.git ~/.cocoapods/repos/master

稍等几十秒,就可以看到下载进度了。(之前下载了三次都失败,而且还超级🐢慢,看这个进度比之前的快多了,瞬间心里得到点小安慰😁)

当进度走完之后,继续执行安装

gem install cocoapods

如果使用 oschina 上的镜像
执行 "pod repo add master http://git.oschina.net/akuandev/Specs.git"
替换索引库镜像的 https://gitcafe.com/akuandev/Specs.git 替换成 http://git.oschina.net/akuandev/Specs.git 即可。

搜索一下库 :
pod search AFNetworking

如果搜索到了就安装成功了,

如果搜索报👇下面的错
[!] Unable to find a pod with name, author, summary, or description matching `AFNetworking `

解决办法

删除cocoapods的索引,执行:
rm ~/Library/Caches/CocoaPods/search_index.json

然后重新search一下,就可以了😊。

推荐阅读更多精彩内容