Flutter 错误记录

 1. Android Studio连接iPhone运行报错:

错误描述:   "Cannot find "xcodebuild". Xcode 9.0 or greater is required to develop for iOS."

解决办法:  sudo xcode-select--switch/Applications/Xcode.app/Contents/Developer


2.pub get failed (65; ╵). exit code 65

多了一行空格。因为yaml格式不正确,谷歌定义的yaml格式太严格了

参考: YAML

3. VSCode 报错 CocoaPods requires your terminal to be using UTF-8 encoding.

解决办法: 

4. Error: The method 'CachedNetworkImageProvider.load' has fewer positional arguments than those of overridden method 'ImageProvider.load'.

解决办法:  

5. Flutter IOS端输入框长按报错The getter 'cutButtonLabel' was called on null' 

解决办法:   https://www.jianshu.com/p/b01495599cd2

6. RenderCustomMultiChildLayoutBox object was given an infinite size during layout.

7.No Material widget found

推荐阅读更多精彩内容