Centos7安装Django

在安装python3.5.3后,由于yum依然是使用就版本,所以更新后的yum不能使用,这个时候需要进入yum进行修改。不修改会报line30的错误, 修改的方法是:

使用vi进行修改,输入vi /usr/bin/yum

把文件头部的#!/usr/bin/python改成#!/usr/bin/python2.7.5保存退出

vi使用起来比较坑爹,不好用,修改过程还把头部的import给改了,导致使用过程报line4的错误。

vi下,I是编辑状态,ESC后转不可编辑模式,退出按: 出键qw或x

vi常用命令:www.cnblogs.com/avril/archive/2010/03/23/1692510.html

yum可以正常使用后,要对系统进行装pip,装pip的方法是到官网下载安装包,地址:pypi.python.org/packages/11/b6/abcb525026a4be042b486df43905d6893fb04f05aac21c32c638e939e447/pip-9.0.1.tar.gz#md5=35f01da33009719497f01a4ba69d63c9

#wget 下载地址后进行解压

然后解压 tar -zxvf ***

解压之后会有个文件夹

进入到文件夹,执行命令python setup.py install

但这个过程会出现报错,提示:没有setuptools

所以要先安装下setuptools。方法是到官网下载安装包,下载地址:pypi.python.org/pypi/setuptools#downloads

(1)下载setuptools包

#wget http://pypi.python.org/packages/source/s/setuptools/setuptools-2.0.tar.gz

(2)解压setuptools包

#tar zxvf setuptools-2.0.tar.gz

(3)切换到当前文件夹

#cd setuptools-2.0

(4)编译setuptools

#python setup.py build

(5)开始执行setuptools安装

#python setup.py install

其中注意,下载的版本,如果是下载2.7版本使用系统已升级的3.0的python进行安装会出现报错的情况。此时若想通过[python2.7进行安装的话需要用命令:python2.7.5 setup.py build 和python2.7.5 setup.py install

安装好setuptools后就可以按上述方法安装pip,同时注意如果是2.7要用python2.7.5进行安装,不然会出现报错。

安装好pip后就可以进行Django安装

安装的方法是:

pip install Django

如果是想用python3进行安装的话要用命令:

pip3 install Django 但在此时安装过程中没成功安装python3.0的pip所以此方法在此时使用过程不可以行。



总结:遇到问题不要慌乱尝试,需要认真看报错信息,分析错误原因再找解决方案。。。。



2017.07.06

推荐阅读更多精彩内容