ZOJ 3497 Mistwald

题目
In chapter 4 of the game Trails in the Sky SC, Estelle Bright and her friends are crossing Mistwald to meet their final enemy, Lucciola.
Mistwald is a mysterious place. It consists of M * N scenes, named Scene (1, 1) to Scene (M, N). Estelle Bright and her friends are initially at Scene (1, 1), the entering scene. They should leave Mistwald from Scene (M, N), the exiting scene. Note that once they reach the exiting scene, they leave Mistwald and cannot come back. A scene in Mistwald has four exits, north, west, south, and east ones. These exits are controlled by Lucciola. They may not lead to adjacent scenes. However, an exit can and must lead to one scene in Mistwald.

Estelle Bright and her friends walk very fast. It only takes them 1 second to cross an exit, leaving a scene and entering a new scene. Other time such as staying and resting can be ignored. It is obvious that the quicker they leave Mistwald, the better.
Now you are competing with your roommate for who uses less time to leave Mistwald. Your roommate says that he only uses P seconds. It is known that he lies from time to time. Thus, you may want to code and find out whether it is a lie.
Input
There are multiple test cases. The first line of input is an integer T ≈ 10 indicating the number of test cases.
Each test case begins with a line of two integers M and N (1 ≤ M, N ≤ 5), separated by a single space, indicating the size of Mistwald. In the next M lines, the ith line contains N pieces of scene information, separated by spaces, describing Scene (i, 1) to Scene (i, N). A scene description has the form "((x1,y1),(x2,y2),(x3,y3),(x4,y4))" (1 ≤ xk ≤ M; 1 ≤ yk ≤ N; 1 ≤ k ≤ 4) indicating the locations of new scenes the four exits lead to. The following line contains an integer Q (1 ≤ Q ≤ 100). In the next Q lines, each line contains an integer P (0 ≤ P ≤ 100,000,000), which is the time your roommate tells you.
Test cases are separated by a blank line.
Output
For each P, output one of the following strings in one line: "True" if it cannot be a lie; "Maybe" if it can be a lie; "False" if it must be a lie.
Print a blank line after each case.
Sample Input
2
3 2
((3,1),(3,2),(1,2),(2,1)) ((3,1),(3,1),(3,1),(3,1))
((2,1),(2,1),(2,1),(2,2)) ((3,2),(3,2),(3,2),(3,2))
((3,1),(3,1),(3,1),(3,1)) ((3,2),(3,2),(3,2),(1,1))
3
1
2
10

2 1
((2,1),(2,1),(2,1),(2,1))
((2,1),(2,1),(2,1),(2,1))
2
1
2
Sample Output
Maybe
False
Maybe

True
False

这个题很久以前组队赛的时候做过,那时候太菜了,不会做
这个题就是把坐标换成邻接矩阵中的一个点,然后对邻接矩阵做一下快速幂运算,然后得到一个数组;这个数组就是走p次后的地图;然后判断p次后是否能正好到达(m,n)点。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct mat
{
    int m[30][30];
}ans;
int x[4],y[4];
int n,m,si;
mat operator * (mat a, mat b)
{
    mat ret;
    int x;
    for(int i=0;i<si;i++)
    {
        for(int j=0;j<si;j++)
        {
            x = 0;
            for(int k=0;k<si;k++)
            {
                x += (a.m[i][k] * b.m[k][j]);
                ret.m[i][j] = x;
            }
        }
    }
    return ret;
}
mat pow_mat(mat a, int x)
{
    mat ret;
    memset(ret.m,0,sizeof(ret.m));
    for(int i=0;i<si;i++)  ret.m[i][i] = 1;
    while(x)
    {
        if(x & 1) ret = ret*a;
        a = a*a;
        x >>= 1;
    }
    return ret;
}
void print(mat tmp)
{
    printf("***************\n");
    for(int i=0;i<si;i++)
    {
        for(int j=0;j<si;j++)
        {
            printf("%8d",tmp.m[i][j]);
        }
        printf("\n");
    }
}
void solve(mat res)
{
    //print(res);
        if(!res.m[0][si-1])
        {
            printf("False\n");
            return ;
        }  
        for(int i=1;i<si-1;i++) 
        {
            if(res.m[0][i])
            {
                printf("Maybe\n");
                return ;
            }  
        }
        printf("True\n");
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        getchar();
        si = n*m;
        memset(ans.m,0,sizeof(ans.m));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                //printf("i = %d, j = %d\n",i,j);
                scanf("((%d,%d),(%d,%d),(%d,%d),(%d,%d))",&x[0],&y[0],&x[1],&y[1],&x[2],&y[2],&x[3],&y[3]);
                getchar();
                if(i== n-1 && j== m-1) continue; 
                int tmp1 = i*m + j;
                for(int k=0;k<4;k++)
                {
                    x[k]-- , y[k]--;
                    int tmp2 = m*x[k] + y[k];
                    ans.m[tmp1][tmp2] = 1;
                }
            }
        }
        //print(ans);
        int q;
        scanf("%d",&q);
        while(q--)
        {
            int tmp;
            scanf("%d",&tmp);
            mat res = pow_mat(ans,tmp);
            solve(res);
        }
        printf("\n");
    } 
}

嗯,这个图实际上就是对一个有向图,通过矩阵乘法实现一个坐标的变换,然后得到结果图去判断能否在指定步数内到达

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 159,117评论 4 362
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 67,328评论 1 293
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 108,839评论 0 243
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 44,007评论 0 206
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 52,384评论 3 287
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 40,629评论 1 219
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 31,880评论 2 313
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 30,593评论 0 198
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 34,313评论 1 243
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 30,575评论 2 246
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 32,066评论 1 260
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 28,392评论 2 253
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 33,052评论 3 236
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 26,082评论 0 8
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 26,844评论 0 195
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 35,662评论 2 274
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 35,575评论 2 270

推荐阅读更多精彩内容

  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 8,578评论 0 23
  • 碎花裙离地 我醉眼迷离 你说先生买朵玫瑰让她带进梦里 今夜正值七夕 灯红酒绿 身处异地,我一人孤身在这里 今日我刚...
    针灸龙哥阅读 369评论 12 5
  • 微商实战专家缘宝揭秘酵素解酒 “敬酒虽好,可不要贪杯喔!”酒有时是喜悦的象征,有时却是灾难的根源。把握敬酒尺度对于...
    美云美云美云阅读 281评论 0 1
  • 一个帖子在求职论坛火了 题目是《普通二本大四狗怎么也找不到实习》 火的原因是下面有一排整齐的队列 写着“我是211...
    优实践阅读 1,166评论 0 2
  • 回顾了一下这两本书,发现这两本书有一个很大的共同点,都在说你的自主行为很多时候是被设计的,想内化引伸一下这两本书,...
    景三harevy阅读 407评论 1 2