cocoapods10.11安装遇到的坑

字数 331阅读 26

参考的文章http://www.cnblogs.com/guanshenbao/p/5534578.html

接下来是精简的步骤过程

3.下载安装CocoaPods

在命令行中输入:

安装:sudo gem install cocoapods

更新:sudo gem update cocoapods

然后就是: pod setup
都安装完成之后就是引入podfile了

4;cd /Users/md098/Desktop/自己工程目录文件夹

终端输入 vim Podfile


键盘输入 i,进入编辑模式,输入

platform :ios, '7.0'

pod 'MBProgressHUD', '~> 0.8'

然后按Esc,并且输入“ :”号进入vim命令模式,然后在冒号后边输入wq


注意:键盘输入 :后,才能输入wq。回车后发现PodTest项目总目录中多一个Podfile文件


接下里就是


终端cd到项目总目录,然后输入 pod install。。。然后你会发现。。。

提示这个错误:[!] The dependency `MBProgressHUD`isnot usedin any concrete target.

原来新的cocoapods不能像之前那样安装第三方了。现在的格式是要加上项目的target。如下:

platform :ios,'8.0'

use_frameworks!

target'MyApp'do

pod 'AFNetworking','~> 2.6'

pod'ORStackView','~> 3.0'

pod'SwiftyJSON','~> 2.3'

end

里面的MyApp记得替换为自己攻城里面的target。这样就基本OK了,执行pod install / pod update 就都可以了。

推荐阅读更多精彩内容