Microsoft 2016 Campus Hiring Contest - April - 1289 : 403 Forbidden

Description
Little Hi runs a web server. Sometimes he has to deny access from a certain set of malicious IP addresses while his friends are still allow to access his server. To do this he writes N rules in the configuration file which look like:
allow 1.2.3.4/30
deny 1.1.1.1
allow 127.0.0.1
allow 123.234.12.23/3
deny 0.0.0.0/0
Each rule is in the form: allow | deny address or allow | deny address/mask.
When there comes a request, the rules are checked in sequence until the first match is found. If no rule is matched the request will be allowed. Rule and request are matched if the request address is the same as the rule address or they share the same first mask digits when both written as 32bit binary number.
For example IP "1.2.3.4" matches rule "allow 1.2.3.4" because the addresses are the same. And IP "128.127.8.125" matches rule "deny 128.127.4.100/20" because 10000000011111110000010001100100 (128.127.4.100 as binary number) shares the first 20 (mask) digits with 10000000011111110000100001111101 (128.127.8.125 as binary number).
Now comes M access requests. Given their IP addresses, your task is to find out which ones are allowed and which ones are denied.
Input
Line 1: two integers N and M.
Line 2-N+1: one rule on each line.
Line N+2-N+M+1: one IP address on each line.
All addresses are IPv4 addresses(0.0.0.0 - 255.255.255.255). 0 <= mask <= 32.
For 40% of the data: 1 <= N, M <= 1000.
For 100% of the data: 1 <= N, M <= 100000.
Output
For each request output "YES" or "NO" according to whether it is allowed.
Sample Input
5 5
allow 1.2.3.4/30
deny 1.1.1.1
allow 127.0.0.1
allow 123.234.12.23/3
deny 0.0.0.0/0
1.2.3.4
1.2.3.5
1.1.1.1
100.100.100.100
219.142.53.100
Sample Output
YES
YES
NO
YES
NO

思路分析
这是这个problem set 4道题的第2道,我以为是一道简单题,即顺序匹配各条规则,然而超时了!
到网上查了思路,是用Trie树来做。需要注意的是,代表规则末尾的节点不仅要记录规则是allow/deny,还需要记录这是第几条规则(index),在匹配阶段,要找到所有匹配的情况,取index最小的匹配。通过建Trie树,每次匹配都是O(1)的!因为树的深度最多是32层,是固定的!确实比暴力匹配好到不知道哪里去了!
不能小看微软的题啊!哪有那么多简单题!总结的经验是,第一题不要想难了,从第二题开始就不要想简单了!

AC代码

//
// Created by Xue Li on 2017/3/21.
//

#include <iostream>
#include <string>

using namespace std;
const int MAX = 100000;

struct Node{
    string state = "";
    Node *left = NULL;
    Node *right = NULL;
    int index;
};

void insertRule(char *s, Node *head, int index);
unsigned getIP(char *s, int left, int right);
void check(Node *head, unsigned ip);
void forbidden();

int main(){
    forbidden();
    return 0;
}

void forbidden(){
    int n, m;
    cin >> n >> m;
    cin.ignore();
    char s[30];
    Node *head = new Node;
    for (int i = 0; i < n; i++){
        cin.getline(s, 30);
        insertRule(s, head, i);
    }

    for (int i = 0; i < m ; i++){
        cin.getline(s, 20);
        int tail = 0;
        while (s[tail] != '\0'){
            tail++;
        }
        unsigned ip = getIP(s, 0, tail);
        check(head, ip);
    }
}

void insertRule(char *s, Node *head, int index){
    string rst;
    int left, i;
    int mask = 32;
    if (s[0] == 'd'){
        rst = "NO";
        left = 5;
    }
    else{
        rst = "YES";
        left = 6;
    }
    i = left;
    while (s[i] != '/' and s[i] != '\0'){
        i+=1;
    }
    unsigned ip = getIP(s, left, i);
    if (s[i] == '/'){
        i += 1;
        mask = 0;
        while (s[i] != '\0'){
            mask = mask * 10 + (s[i] - '0');
            i++;
        }
    }
    Node *p = head;
//    用digit这个变量,来和ip的相与,能够得到ip的每一位!
    unsigned digit = (unsigned)1 << 31;
    for (int i = 0; i < mask; i++){
        if ((ip & digit) == 0){
            if (p->left == NULL){
                Node* child = new Node;
                p->left = child;
            }
            p = p->left;
        }
        else{
            if (p->right == NULL){
                Node* child = new Node;
                p->right = child;
            }
            p = p->right;
        }
        digit >>= 1;
    }
    if (p->state == ""){
        p->state = rst;
        p->index = index;
    }
}

void check(Node *head, unsigned ip){
    unsigned digit = (unsigned)1 << 31;
    int index = MAX + 1;
    string state = "YES";
    Node *p = head;
    if (p->state != "" && p->index < index) {
        index = p->index;
        state = p->state;
    }
    for (int i = 0; i < 32; i++){
        if ((ip & digit) == 0){
            p = p->left;
            if (p == NULL)
                break;
        }
        else{
            p = p->right;
            if (p == NULL)
                break;
        }
        if (p->state != "" && p->index < index) {
            index = p->index;
            state = p->state;
        }
        digit >>= 1;
    }
    cout << state << endl;
}

unsigned getIP(char *s, int left, int right){
    int i = left;
    unsigned ip = 0;
    int d = 0;
    while (i < right){
        if (s[i] == '.'){
            ip = ip << 8;
            ip += d;
            d = 0;
        }
        else{
            d = d * 10 + (s[i] - '0');
        }
        i += 1;
    }
    ip = ip << 8;
    ip += d;
    return ip;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 159,835评论 4 364
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 67,598评论 1 295
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 109,569评论 0 244
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 44,159评论 0 213
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 52,533评论 3 287
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 40,710评论 1 222
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 31,923评论 2 313
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 30,674评论 0 203
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 34,421评论 1 246
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 30,622评论 2 245
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 32,115评论 1 260
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 28,428评论 2 254
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 33,114评论 3 238
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 26,097评论 0 8
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 26,875评论 0 197
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 35,753评论 2 276
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 35,649评论 2 271

推荐阅读更多精彩内容