apache配置SSL支持https

96
黄秀杰
2017.03.31 00:50* 字数 522

制作自签证书

参考了文章https://my.oschina.net/angelangel/blog/387978

环境是phpStudy+win2003+mac

考虑到windows还要另外找openssl工具(起先不知道phpstudy已然自带),就在mac下生成自签证书。

制作的过程一路Next,回答问题都比较顺利。注意的是,如上文所述,server name要与最终apache配置的要相一致

apache配置

期间遇到了apache启动即停止的问题,而phpStudy不像Xampp那样有日志输出,懵了一阵;然后win+r,cmd中运行httpd.exe,能看到具体提示的信息,到底是哪些xml配置有误,按提示相应地做处理就行了。

运行https总算成功后,get/post都能取到值;用Postman的去请求,要给自己刚刚生成的证书才行。

postman-warn.png
post-crt.png

而用chrome浏览器访问有会有一个警告。

https-warn.png

小程序对TSL版本要求

又遇到小程序要求TSL大于1.2版本的问题。

tls_version1.2.png

power shell运行一段命令。

由于主机是win2003,需要另外安装power shell,而power shell又是依赖.net framework,一路装上后再来运行注册表信息。

期间报了一个目录已存在的红色错误。

又重启试了一次。还是不行。

还有一种方式,就是把命令行写进.reg,双击运行也是同理,这样就不用装power shell以及.net framework。

继续搜索,发现win2003并不支持TLS1.2,以上的活白忙了。只能升级2008rc以上才可以了。

源于文章:http://www.jb51.net/article/106398.htm

附加一个TLS版本依赖图例

TLS版本对比

参考了文章:http://blog.csdn.net/yuanjuxiong/article/details/55518875

宣告失败

到此宣告失败,除非升级服务器操作系统。

ps:后来发现,阿里云主机,其实也提供了20个免费证书可用,跟腾讯云是有免费的。

阿里云ssl证书
小程序