webpack+swiper


之前在做项目的时候 webpack 中使用swiper会出现 error:Cannot assign to read only property 'exports' of object '#<Object>' 似乎是exports和import不兼容引起的

网上有很多解决办法,但都不尽如人意。这里介绍一种比较好的兼容办法
需要引入插件

  • npm install babel-plugin-transform-es2015-modules-commonjs

    然后在 babelrc中配置

  • { "plugins": ["transform-es2015-modules-commonjs"] }
    即可解决

推荐阅读更多精彩内容