CocoaPods问题

  • 安装CocoaPods完成之后, 执行 pod install后会出现[!] The `master` repo requires CocoaPods 1.0.0 - (currently using 0.35.0) 这个问题

解决办法就是: 在终端中执行下面的指令, 将其主线切换到较低版本
cd ~/.cocoapods/repos/master/
git fetch origin master
git checkout v0.32.1

  • 还有一种情况就是执行git fetch origin master之后 没有办法切换到v0.32.1 此时执行 pod repo update --verbose 就会出现下面的情况
$ pod repo update --verbose
Updating spec repo `master`
  Performing a deep fetch of the `master` specs repo to improve future
  performance
    $ /usr/bin/git fetch --unshallow
    From https://github.com/CocoaPods/Specs
     * [new tag]         20161019   -> 20161019
     * [new tag]         v0.32.1    -> v0.32.1

此时就可以执行git checkout v0.32.1 就OK了
参考网址

推荐阅读更多精彩内容