ButterKnife使用

  • 依赖butterknife包
    右键项目->点击“Open Module Settings”->点击“dependencies”->点击“+”->选择butterknife包
    效果如下

    compile 'com.jakewharton:butterknife:7.0.1'
    
注意:直接依赖的butterknife的版本是5.1.1,后续的bind操作无法继续,须改成7.0.1
  • 使用
    必须先在setContentView()之后声明
    ButterKnife.bind(this);
    在onCreate之前使用

    @Bind(R.id.opera_toolbar)
     Toolbar Opera_TB;
    
     @OnClick(R.id.FAB_btn) void FAB_btn(){
          //处理点击事件
    }
    

推荐阅读更多精彩内容