1.0版本Cocoapods —— podfile变更

Pods written in Swift can only be integrated as frameworks; add use_frameworks!
to your Podfile or target to opt into using it. The Swift Pods being used are:
Box, ReactiveCocoa, and Result

大概意思是:苹果不允许建包含swift的静态库,不同于OC可以使用平台版本的语言版本。

Podfile的配置文件为:
一开始我安装oc的配置方法:
source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0' target 'RWReactivePlayground' do
pod 'ReactiveCocoa', '~> 3.0'
end

解决方法:#use_frameworks!个别需要用到它,比如reactiveCocoa
source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
target 'RWReactivePlayground' do
pod 'ReactiveCocoa', '~> 3.0' use_frameworks!
end

对于多个框架的添加
Podfile的配置文件为:
platform:ios,'8.0'
def
pods
pod 'AFNetworking', '~> 2.6'
pod 'ORStackView', '~> 3.0'
pod 'SwiftyJSON', '~> 2.3'end
target 'MyApp'do pods
end

推荐阅读更多精彩内容