Cocoa pods安装中出现的问题

今天跟大家来讨论一下cocoapods安装:

相信大家安装的时候都经历了头疼的问题,不知道要安装什么?虽然在网上一找好多

但是大多都不够详细,今天就跟大家分享一下心得

要用cocoapods 就要安装ruby,ruby的安装环境要用RVM

这些是什么呢?其实无外乎就是一些命令行(不啰嗦 下面给大家一一列出)

大家记住安装的先后顺序 RVM -- RUBY -- 

1./usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"或者curl -L https://get.rvm.io | bash -s stable 都可以

2.$ source ~/.rvm/scripts/rvm 检查一下是否安装正确 $ rvm -v

3.用rvm安装ruby版本 列出已知的ruby版本

$ rvm list known

下面以rvm 2.4.1版本的更新为例

$ rvm install 2.4.1

更新完成以后 查看一下安装的版本是否正确 然后把它保存默认 $ rvm 2.4.1 --default

好了重点来了就在这更新的中间我遇到了Error 大家可以参考一下

这个问题让我控扰了好半天,解决办法:

(1).终端输入 xcode-select --install

(2). 此时会弹出一个软件安装信息 点击安装 安装结束后继续在终端输入rvm install 2.4.1

并且它的镜像就是已经改好的https://gems.ruby-china.org/ 大家可以查一下

推荐阅读更多精彩内容