PAT Advanced 1024. Palindromic Number (25) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

A number that will be the same when it is written forwards or backwards is
known as a Palindromic Number. For example, 1234321 is a palindromic
number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of
operations. First, the non-palindromic number is reversed and the result is
added to the original number. If the result is not a palindromic number, this
is repeated until it gives a palindromic number. For example, if we start from
67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 +
341 = 484.

Given any positive integer N , you are supposed to find its paired
palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive
numbers N and K , where N ( \le 10^{10} ) is the initial numer and K
( \le 100 ) is the maximum number of steps. The numbers are separated by a
space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is
the paired palindromic number of N , and the second number is the number of
steps taken to find the palindromic number. If the palindromic number is not
found after K steps, just output the number obtained at the K th step and
K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

思路

结合考察大数计算和回文数,和1023题很相似,涉及到的操作有:

  • 翻转
  • 两数相加
  • 判断回文数

相加的函数和1023中翻倍的写法很像,只不过是把当前位乘二换为相加,
因为这道题是和自己的翻转数相加,所以我代码中没有考虑两数长度不同的情况,
在更广泛的应用中,切记要考虑两不同长度的大数相加的处理。

P.S. 我的处理和1023题中也一样,是倒序存储数字的,所以开头结尾要翻转过来才可以。

字符串长度:这道题,字符串长度取得很宽松,实际上极限可能就是60位左右,不要取得过小。

代码

最新代码@github,欢迎交流

#include <stdio.h>
#include <string.h>

int isPalindromic(char n[])
{
    int len = strlen(n);
    for(int i = 0; i < len / 2; i++)
        if(n[i] != n[len - i - 1])
            return 0;
    return 1;
}

char* reverse(char n[])
{
    char temp;
    int len = strlen(n);
    for(int i = 0; i < len / 2; i++)
    {
        temp = n[i];
        n[i] = n[len - i - 1];
        n[len - i - 1] = temp;
    }
    return n;
}

/* only works when a and b are of the same length */
void addAtoB(char a[], char b[])
{
    int l, s = 0, len = strlen(a);

    for(int i = 0; i < len; i++)
    {
        s += (a[i] - '0') + (b[i] - '0');
        l = s / 10;
        s %= 10;
        b[i] = s + '0';

        s = l;
    }

    if(s)
        b[len] = s + '0';
}

int main()
{
    int K, steps;
    char s1[100] = {0}, s2[100] = {0}, *n = s1, *m = s2;

    scanf("%s %d", n, &K);
    reverse(n);

    for(steps = 0; steps < K && !isPalindromic(n); steps++)
    {
        /* change 'm' into reverse of 'n' */
        strncpy(m, n, 100);
        reverse(m);
        /* add n and reversed n, and keep the result in n */
        addAtoB(m, n);
    }

    printf("%s\n%d", reverse(n), steps);

    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 159,117评论 4 362
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 67,328评论 1 293
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 108,839评论 0 243
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 44,007评论 0 206
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 52,384评论 3 287
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 40,629评论 1 219
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 31,880评论 2 313
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 30,593评论 0 198
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 34,313评论 1 243
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 30,575评论 2 246
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 32,066评论 1 260
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 28,392评论 2 253
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 33,052评论 3 236
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 26,082评论 0 8
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 26,844评论 0 195
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 35,662评论 2 274
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 35,575评论 2 270

推荐阅读更多精彩内容