PAT Advanced 1028. List Sorting (25) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

Excel can sort records according to any column. Now you are supposed to
imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains
two integers N ( \le 10^5 ) and C , where N is the number of records
and C is the column that you are supposed to sort the records with. Then N
lines follow, each contains a record of a student. A student's record consists
of his or her distinct ID (a 6-digit number), name (a string with no more than
8 characters without space), and grade (an integer between 0 and 100,
inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C =
1 then the records must be sorted in increasing order according to ID's; if
C = 2 then the records must be sorted in non-decreasing order according to
names; and if C = 3 then the records must be sorted in non-decreasing order
according to grades. If there are several students who have the same name or
grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

思路

应该也是很基本的排序。三种排序选项,后两个还有二级排序。也没有什么特殊的处理,所以很简单。

代码

最新代码@github,欢迎交流

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef struct {
    int ID;
    char name[9];
    int grade;
} Student, *pStudent;

/* increasing by ID */
int cmp1(const void *a, const void *b)
{
    pStudent s1 = *(pStudent*)a, s2 = *(pStudent*)b;
    return s1->ID - s2->ID;
}

/* non decreasing by name, then increasing by ID */
int cmp2(const void *a, const void *b)
{
    pStudent s1 = *(pStudent*)a, s2 = *(pStudent*)b;
    if(strcmp(s1->name, s2->name))
        return strcmp(s1->name, s2->name);
    else
        return s1->ID - s2->ID;
}

/* non decreasing by grade, then increasing by ID */
int cmp3(const void *a, const void *b)
{
    pStudent s1 = *(pStudent*)a, s2 = *(pStudent*)b;
    if(s1->grade - s2->grade)
        return s1->grade - s2->grade;
    else
        return s1->ID - s2->ID;
}

int main()
{
    int N, C;
    Student buffer[100000] = {0};
    pStudent students[100000] = {0}, *s = students;

    scanf("%d %d", &N, &C);
    for(int i = 0; i < N; i++, s++)
    {
        /* use a new struct buffer */
        *s = buffer + i;
        scanf("%d %s %d", &(*s)->ID, (*s)->name, &(*s)->grade);
    }

    if(C == 1)  /* increasing ID */
        qsort(students, N, sizeof(pStudent), cmp1);
    else if(C == 2)  /* non-decreasing name */
        qsort(students, N, sizeof(pStudent), cmp2);
    else  /* C == 3, non-decreasing grade */
        qsort(students, N, sizeof(pStudent), cmp3);

    for(int i = 0; i < N; i++)
        printf("%06d %s %d\n", students[i]->ID,
                               students[i]->name,
                               students[i]->grade);

    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 158,847评论 4 362
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 67,208评论 1 292
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 108,587评论 0 243
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 43,942评论 0 205
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 52,332评论 3 287
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 40,587评论 1 218
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 31,853评论 2 312
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 30,568评论 0 198
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 34,273评论 1 242
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 30,542评论 2 246
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 32,033评论 1 260
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 28,373评论 2 253
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 33,031评论 3 236
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 26,073评论 0 8
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 26,830评论 0 195
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 35,628评论 2 274
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 35,537评论 2 269

推荐阅读更多精彩内容