MacOSX启动项


Introduction & Overview

  1. 或许你会对MacOS启动的哪些程序感到好奇
  2. MacOS启动的时间貌似变长了些许
  3. 为什么有些来历不明的程序总是在左右着你

Points

  • OSX : Powered up > Firmware In Complete Control(Hardware) > BootX Loader(Kernel) > BSD Subsystem > Aqua User Interface

  • BootX: Located in /System/Library/CoreServices > Loads Kernel Extensions (drivers, also known as kexts:/System/Library/Extensions)

  • Initialization:Data Structures > I/O Kit > Mounts the root filesystem > loads mach_init > Launches the BSD init process >

  • The init process launches:

    • shell scripts to start the system /etc/rc.boot and /etc/rc
    • sets the initial environment /etc/rc.common
    • load usefull functions/etc/hostconfig
  • /etc/rc enables the swap file, sets the language for the system, and hands off control to /sbin/SystemStarter.

  • SystemStarter:

    • examines /System/Library/StartupItems and /Library/StartupItems for applications that should be started at boot time.
  • Returned to init, which launchesgetty, the console entry launches Login Window (/System/Library/CoreServices/loginwindow.app).

  • Run Services in macOS

    • launchd is the cron in macOS
    • launchd distinguishes daemons and agents.
  • Two main components in the launchd service

    • Job Definition : Define the service in special XML file.
    • Operations : Control the service using command line utility.
  • Job Definition

    • The behavior of a daemons or agents are defined in a special XML file called a property list (*.plist) file.
  • Type Location Run On Be Half Of
    User Agents ~/Library/LaunchAgents Current Logined In User
    Global Agents /Library/LaunchAgents Current Logined In User
    Global Daemons /Library/LaunchDaemons Root Or the User Specify with Key Username
    System Agents /System/Library/LaunchAgents Current Logined In User
    System Daemons /System/Library/LaunchDaemons Root Or the User Specify with Key Username

    Operations.

    Getting information about available (loaded) jobs :

    $ launchctl list
    

    Getting information about a given job :

    $ launchctl list | grep <LABEL>
    

    Loading/Unloading a job (a global daemon) :

    $ launchctl load/unload /Library/LaunchDaemons/<LABEL>.plist
    

    Starting/Stop/Restart a job (a loaded job) :

    $ launchctl start/stop/restart <LABEL>
    

Simple Example

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN"
    "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>org.wso2.am</string>
    <key>ServiceDescription</key>
    <string>WSO2 API Manager Server</string>
    <key>ProgramArguments</key>
    <array>             
        <string>/bin/wso2server.sh</string>
    </array>
    <key>RunAtLoad</key>
    <false/>
</dict>
</plist>

Load & Run:

$ sudo launchctl load /Library/LaunchDaemons/org.wso2.am.plist
$ sudo launchctl start org.wso2.am

Test & Taste

$ sudo launchctl list | grep org.wso2.am

Bonus

#!/bin/bash

mkdir ~/.startup
# mac os startup item place , <sudo launchctl list> is ok also. 
ln -s /System/Library/StartupItems ~/.startup/sysStartupItems
ln -s /Library/StartupItems ~/.startup/libStartupItems
ln -s ~/Library/LaunchAgents ~/.startup/userAgents
ln -s /Library/LaunchAgents ~/.startup/libAgents
ln -s /Library/LaunchDaemons ~/.startup/libDaemons
ln -s /System/Library/LaunchDaemons ~/.startup/sysDaemons
ln -s /System/Library/LaunchAgents ~/.startup/sysAgents

function searchstartup(){
        grep -lrn $1 ~/.startup
}

Ref

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 159,015评论 4 362
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 67,262评论 1 292
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 108,727评论 0 243
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 43,986评论 0 205
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 52,363评论 3 287
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 40,610评论 1 219
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 31,871评论 2 312
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 30,582评论 0 198
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 34,297评论 1 242
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 30,551评论 2 246
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 32,053评论 1 260
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 28,385评论 2 253
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 33,035评论 3 236
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 26,079评论 0 8
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 26,841评论 0 195
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 35,648评论 2 274
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 35,550评论 2 270