Wrong full snapshot version, expected ‘xxx' found ‘xxx'

出现时机

一般在更新flutter 之后出现: flutter upgrade

出现原因

目前不清楚

解决方式

  • 方式1 :

删除安装包,重新flutter run

  • 方式2:(it works for me)

删除 ~/flutter/bin/cache, 然后 flutter clean

  • 方式3:

git clean -xffd

备注:解决方式的代价从小到大,建议从1到3开始尝试

推荐阅读更多精彩内容