防火墙

如图所示配置好接口和主机、服务器的IP地址

路由器0:

Router(config)#ip nat pool p1 202.96.1.10 202.96.1.10 netmask 255.255.255.0【IP NAT地址转换】

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255【ACL】

Router(config)#ip nat inside source list 1 pool p1 overload

Router(config)#interface f0/1【内网口】

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#interface f0/0

Router(config-if)#ip nat outside【外网口】

Router(config-if)#exit

Router(config)#ip route 202.96.2.0 255.255.255.0 202.96.1.2【跨网段-要做路由】

主机0>ping 202.96.2.2---------可通

主机1>ping 192.168.1.2----------主机不可达

路由器0:

Router(config)#ip nat inside source static 192.168.1.3 202.96.1.3【静态】

主机1>访问内网的www服务器:url:202.96.1.3------>可通

主机0>访问外网的www服务器:url:202.96.2.3------>可通

内网主机0访问外网的ftp------可以

为了使外网访问不了内网的ftp服务,则配置扩展ACL

Router(config)#access-list 100 permit tcp any host 202.96.1.3 eq 80

Router(config)#access-list 100 permit tcp any any established

Router(config)#interface f0/0

Router(config-if)#ip access-group 100 in

外网主机1连接内网ftp------>不可通

推荐阅读更多精彩内容