11.6.1:综合技巧练习 - 配置并测试网络

实验环境:packet Tracer5.0

实验拓补如下:

实验要求:

Learning Objectives:

创建、测试并配置整个实验网络

综合运用整套课程中学到的技巧

分析请求网页所涉及的事件(DNS、ARP、HTTP、TCP、IP、Ethernet、HDLC)

分析在跟踪到 Web 服务器的路由时所涉及的事件(DNS、UDP、ARP、ICMP、IP、Ethernet、HDLC)

背景:

整套课程始终着意于培养您的网络规划、构建、配置和测试技能。同时也让学生从概念上了解网络协议。下面将让您进行一次自我测验。

在本 Packet Tracer 技巧综合练习实验中,您将创建、分配地址、配置并测试整个课程中使用的标准实验拓扑。

任务 1:计划使用标准 Exploration 实验拓扑计划 IP 编址方案:

两台 1841 路由器,其 WIC-2T 接口卡安装在右手插槽中(一个名为 R1-ISP,通过串行 DCE WAN 连接到 R2-Central,通过 Fa0/0 LAN 连接到 Eagle_Server;另一个名为 R2-Central,通过串行 DTE WAN 连接到 R1-ISP,通过 Fa0/0 LAN 连接到 S1-Central)

一台 2960TT 交换机 (S1-Central)

两台 PC,分别名为 1A 和 1B

一台服务器,名为 Eagle_Server。

请注意,必须准确配置所有设备的显示名称和主机名称,一般而言,必须完全按照这些说明键入所有字符串(名称、密码和标语),Packet Tracer 才能正确为练习评分。

为您分配的 IP 地址块为 192.168.3.0 /24,您必须支持现有的网络,同时还要考虑未来的发展。

子网的具体情况为:

第 1 个子网为现有的学生 LAN,最多支持 28 台主机(R2-Central 上的 Fa0/0,连接到 S1-Central 上的 Fa0/24)

第 2 个子网为未来的学生 LAN,最多支持 28 台主机(尚未实施)

第 3 个子网为现有的 ISP LAN,最多支持 14 台主机(R1-ISP 上的 Fa0/0)

第 4 个子网为未来的 ISP LAN,最多支持 7 台主机(尚未实施)

第 5 个子网为现有的 WAN,采用点到点链路(R1-ISP 上的 S0/0/0 和 R2-Central 上的 S0/0/0)

IP 地址的具体情况为:

对于服务器,配置 ISP LAN 子网中可用的第二大 IP 地址。

对于 R1-ISP 的 Fa0/0 接口,配置 ISP LAN 子网中可用的最大 IP 地址。

对于 R1-ISP 的 S0/0/0 接口,配置现有 WAN 子网中可用的最大地址。

对于 R2-Central 的 S0/0/0 接口,使用现有 WAN 子网中可用的最小地址。

对于 R2-Central 的 Fa0/0 接口,使用现有学生 LAN 子网中可用的最大地址,并将其连接到 S1-Central 上的 Fa0/24 接口。

对于主机 1A 和 1B,使用现有学生 LAN 子网中的前两个 IP 地址(可用的两个最小地址),并将它们分别连接到 S1-Central 上的 Fa0/1 和 Fa0/2 接口。

对于主机管理接口,使用学生子网中可用的第二大地址。

任务 2:创建并配置网络

创建网络,按照说明进行连接。配置两个路由器、交换机、服务器及两台 PC。

使用 CLI 配置路由器。路由器配置必须包括 "housekeeping"(主机名、密码和标语)、接口(FastEthernet 和 Serial)和路由(R1-ISP 上的静态路由,R2-Central 上的默认路由)。以下登录密码应全部设置为 "cisco"(不含引号):使能口令、控制台和 Telnet。标语内容应为**这是实验路由器 R1-ISP,未经授权,禁止使用。**以及**这是实验路由器 R2-Central,未经授权,禁止使用。**

接口应按照以上 IP 编址章节的说明配置;在 R1-ISP S0/0/0 接口上使用时钟速率 64000。R1-ISP 上的静态路由应通过 R2-Central 的串行接口 IP 地址指向现有的学生 LAN 子网;R2-Central 上的静态路由应是通过 R1-ISP 串行接口 IP 地址指向的默认静态路由。只要配置了 Cisco IOS 设备,请务必保存配置。

在交换机配置主机名、标语(**这是实验交换机 S1-Central,未经授权,禁止使用。**)、访问的登录密码(使能加密口令、控制台密码和 Telnet 密码都设置为 "cisco")和管理接口 (interface vlan1)。只要配置了 Cisco IOS 设备,请务必保存配置。

对于主机 1A 和 1B,除了 IP 配置之外,还要配置它们使用 DNS 服务。对于服务器,需启用 DNS 服务,使用域名 eagle-server.example.com,并且启用 HTTP 服务。

在工作时,可使用 "Check Results"(检查结果)查看仍需配置的组件。如果需要更多练习,可使用 "Reset Activity"(重置练习)按钮,并且重新计时,再次完成整个配置。

任务 3:测试和分析建议通过 ping 和 Telnet 测试连通性并检查路由表。当您确信网络可以运行之后,确保将配置保存在 Cisco IOS 设备中。然后重新启动设备,并重置网络。在模拟模式中请求网页,使以下协议显示在事件列表中:DNS、HTTP、Telnet、TCP、UDP、ICMP、ARP。检查设备处理时的数据包,以研究协议行为,特别是 IP 如何参与所有活动。另请注意主机、交换机和路由器使用的算法。向同学说明整个过程。再次重新启动设备以清除网络配置,仍然保持在模拟模式中,从一台 PC 向服务器发出 traceroute。研究 ICMP 回应请求如何构成跟踪。再次向同学说明整个过程。

思考:汇总归纳

将任务 3 中观察到的过程与 TCP/IP 协议图对应起来。在 Packet Tracer 中创建网络模型的技巧对于学习后面的课程很有用。


1、配置所有设备的显示名称和主机名称,一般而言,必须完全按照这些说明键入所有字符串(名称、密码和标语)

设置名称、关闭每台设备的域名查找功能(no ip domain-lookup):

Eagle_Server


R1-ISP

```

Router>enable

Router#conf terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no ip domain-lookup

Router(config)#hostname R1-ISP

R1-ISP(config)#

```

R2-Central

```

Router>

Router>enable

Router#conf terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2-Central(config)#no ip domain-lookup

Router(config)#hostname R2-Central

R2-Central(config)#

```

S1-Central

```

Switch>

Switch>enable

Switch#conf terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#hostname S1-Central

S1-Central(config)#

```

2、给路由和交换机设置登录标语banner   输入标语后面要以#号结束

R1-ISP

```

R1-ISP(config)#banner motd #

Enter TEXT message.  End with the character '#'.

** This is the experimental router R1-ISP, unauthorized, prohibited use. ** #

```

R2-Central

```

R2-Central(config)#banner motd #

Enter TEXT message.  End with the character '#'.

** This is the experimental router R2-Central, unauthorized, prohibited use. **#

```

S1-Central

```

S1-Central(config)#banner motd #

Enter TEXT message.  End with the character '#'.

** This is the experimental switch S1-Central, unauthorized, prohibited. **#

```

3、给每台设备配置地址

Eagle Server

PC 1A


PC 1B


R2-Central

```

R2-Central(config)#interface fastEthernet 0/0

R2-Central(config-if)#ip address 192.168.3.30 255.255.255.224

R2-Central(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2-Central(config-if)#exit

R2-Central(config)#interface serial 0/0/0

R2-Central(config-if)#ip address 192.168.3.97 255.255.255.252

R2-Central(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

```


R1-ISP

```

R1-ISP(config)#interface fastEthernet 0/0

R1-ISP(config-if)#ip address 192.168.3.78 255.255.255.240

R1-ISP(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1-ISP(config-if)#exit

R1-ISP(config)#interface serial 0/0/0

R1-ISP(config-if)#ip address 192.168.3.98 255.255.255.252

R1-ISP(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

R1-ISP(config-if)#

```

S1-Central

```

S1-Central(config)#interface vlan 1

S1-Central(config-if)#ip address 192.168.3.29 255.255.255.224

S1-Central(config-if)#no shutdown

%LINK-5-CHANGED: Interface Vlan1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

S1-Central(config-if)#

```

4、在 R1-ISP S0/0/0 接口上使用时钟速率 64000

```

R1-ISP(config)#interface serial 0/0/0

R1-ISP(config-if)#clock rate 64000

R1-ISP(config-if)#no shutdown

R1-ISP(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

```

5、服务器,需启用 DNS 服务,使用域名 eagle-server.example.com,并且启用 HTTP 服务

开启http服务


开启DNS Serive ,Name:eagle-server.example.com    address:192.168.3.77   然后添加

6、设置静待路由和默认路由

R1-ISP

```

R1-ISP(config)#ip route 192.168.3.0 255.255.255.224 192.168.3.97

R1-ISP(config)#

```

R2-Central

` R2-Central(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.98 `

7、设置密码

R1-ISP

```

R1-ISP(config)#line console 0

R1-ISP(config-line)#password cisco

R1-ISP(config-line)#login

R1-ISP(config-line)#exit

R1-ISP(config)#line vty 0 4

R1-ISP(config-line)#password  cisco

R1-ISP(config-line)#login

R1-ISP(config-line)#exit

```

R2-Central

```

R2-Central(config)#line console 0

R2-Central(config-line)#password cisco

R2-Central(config-line)#login

R2-Central(config-line)#exit

R2-Central(config)# line vty 0 4

R2-Central(config-line)#password cisco

R2-Central(config-line)#login

R2-Central(config-line)#exit

```

S1-Central

```

S1-Central(config)#line console 0

S1-Central(config-line)#password cisco

S1-Central(config-line)#login

S1-Central(config-line)#exit

S1-Central(config)#line vty 0 4

S1-Central(config-line)#password cisco

S1-Central(config-line)#login

S1-Central(config-line)#exit

```

PS:一般密码最后配置,不然中间配置其他命令的时候要一直输密码。

推荐阅读更多精彩内容