mac上安装django

在学习python的过程中,django差不多是必学的东西,今天记录一下mac上安装django的过程。

因为mac自带python2.7的版本,但现在python已经使用到python3,所以在一开始学习的时候,我另外安装了python3.5的版本,现在mac上共存python2.7和python3.5两个版本,由此就有问题了啊,在shell中启动解释器的时候,怎么启动想要的解释器呢,在我还不懂的时候,我对这个问题进行了百度,答案五花八门,有说卸载旧版本的,这样一启动就是新版本,还有说修改默认启动路径的,因为默认启动的是2.7的自带,那个修改默认路径的过程太繁琐,修改的东西太多我看了两行就没看了。但是研究了一下发现,再启动解释器的时候,输入python,就是启动python2.7,输入python3,就是启动3.5,哈哈这样一来就太方便了。最后,不建议卸载旧版本的python2.7,据说对于需要使用Xcode的同学来说,这个是有用的。

接下来说一下django的安装。我是通过一个叫pip的依赖管理工具安装的,同样的,这个东西mac自带,但是版本挺低的,在shell中输入pip,如果不报错,弹出一大堆东西,就说明这个是存在的。在这里又涉及到版本的问题了。

$ pip install django

就可以安装django了,注意,这里安装的是python2.7那个版本的,如果需要安装python3.5的,直接:

$ pip3 install django

这里可能会说pip版本太低需要升级,那么输入:

$ pip3 install --upgrade pip

先升级,在进行django安装,安装完成以后,在shell中试一下:

只要在引入模块的时候不报错,就说明安装成功了。

推荐阅读更多精彩内容