brew安装指定版本的Python / 解决Macbook上Python3.7版本不能安装Tensorflow的问题

[原创文章,转载请注明出处]

最近想在Macbook上搭建tensorflow环境,发现pip安装会报错,说找不到合适版本的tensorflow。通过pip3 install -v tensorflow发现目前只提供了python3.5和python3.6的pip安装包。而前段时间brew自动更新,python3已经变成了3.7.0版本,所以安装失败。

Python 3.7是新推出的,相信过一段时间tensorflow也会相应推出匹配python 3.7的安装包,但现在还是要解决安装的问题。

两个办法:

  1. 源码编译python 3.6
  2. brew指定安装python 3.6版本

以在Linux上的python安装经验,源码编译还得解决ssl,zlib等依赖。而且在brew上安装指定版本的软件是个更通用的方法,研究了以后安装其它软件也用的上,所以选择了调查第二种方法。

在网上找了一圈,brew tapbrew versions等的办法都已经过时了。现在的brew可以直接通过brew search xxx@来查看一个软件在brew提供的所有版本,然后通过@来指定安装的版本。

看了一下python3,发现只有3这个大版本号,查看python也是类似的:

Mac% brew search python3@
==> Formulae
boost-python3        python3 ✔        python@3 ✔

所以没法直接指定版本号了。

最后在StackOverflow的这个帖子里找到了可以参考的方法。但可能年代久远,还需要修正一下。下面开始介绍。


步骤1: 将brew的本地git repo切换到包含指定历史版本

locate Formula/python.rb

先找到brew的本地git repo,我是通过上面的locate命令找到的,在/usr/local/Homebrew/Library/Taps/homebrew/homebrew-core/Formula。跳到这个目录

cd /usr/local/Homebrew/Library/Taps/homebrew/homebrew-core/Formula
git log python.rb

翻了一个git log,发现在这个commit里是有python 3.6的

commit f2a764ef944b1080be64bd88dca9a1d80130c558
Author: BrewTestBot <brew-test-bot@googlegroups.com>
Date:   Sun Jun 17 13:24:46 2018 +0000

    python: update 3.6.5_1 bottle.

于是切换到这个版本

git checkout f2a764
...
HEAD is now at f2a764ef9... python: update 3.6.5_1 bottle.

步骤2: 重新安装python 3.6

Mac% brew install python3
Error: python 3.7.0 is already installed
To install 3.6.5_1, first run `brew unlink python`
Mac% brew unlink python3
Unlinking /usr/local/Cellar/python/3.7.0... 16 symlinks removed

直接安装会报个错,需要先unlink。这时再安装就没问题了。注意的是要加上--with-brewed-openssl参数,否则后面ssl模块会import不了,使用pip也会报错。

brew install python --with-brewed-openssl

检查一下

Mac% python3 -V
Python 3.6.6

Mac% ll /usr/local/bin/python*
lrwxr-xr-x  1 root  staff        9 Aug 18 08:49 /usr/local/bin/python3 -> python3.6
lrwxr-xr-x  1 root  staff       16 Aug 18 08:49 /usr/local/bin/python3-config -> python3.6-config
-rwxr-xr-x  2 root  staff  3005736 Aug 18 08:49 /usr/local/bin/python3.6
lrwxr-xr-x  1 root  staff       17 Aug 18 08:49 /usr/local/bin/python3.6-config -> python3.6m-config
-rwxr-xr-x  2 root  staff  3005736 Aug 18 08:49 /usr/local/bin/python3.6m
-rwxr-xr-x  1 root  staff     2042 Aug 18 08:49 /usr/local/bin/python3.6m-config

显示的是3.6.6而不是git log里写的3.6.5_1,不过应该不是什么问题了。

这时候再按正常步骤安装tensorflow也可以正常使用了(建议通过virtualenv安装)。

步骤3: 收尾

最后重新执行link(因为3.7.0已经安装过,以后需要的时候再指定link到3.7.0版本也是ok的)

brew link --overwrite python3

并且将git repo恢复

git checkout master

为了避免下次brew自动升级时又重新安装3.7,关闭brew的自动更新,在.zshrc或.bashrc中加上

export HOMEBREW_NO_AUTO_UPDATE=true

总结

  1. 这个方法适用于brew指定安装其它软件在brew提供过的任何历史版本。
  2. 为了避免brew自动更新带来的麻烦(之前还出现过brew自动升级一半超时失败后,使rb文件格式不兼容,所有软件都不能安装的问题),关闭自动更新可能是个好主意。