2019-08-21 pandas导入excel出错

错误如下:

ImportError: Pandas requires version '1.1.0' or newer of 'xlrd' (version '1.0.0' currently installed).

即xlrd的版本有点低,需要更新。

使用以下命令:

pip install --upgrade xlrd

可以看出,xlrd从1.0.0升级到1.2.0版本,问题解决。

Successfully uninstalled xlrd-1.0.0
Successfully installed xlrd-1.2.0

推荐阅读更多精彩内容