三级网络技术第7章:路由器及其配置(三)

相同类型的习题反复训练,是提高对题目敏感程度的手段之一。

一. 路由器的静态路由配置

1. 静态路由应用

1)手工配置

适合小型、拓扑无变化的局域网和点到点的网络环境。

2)实例

化工大学千兆以太网与北京大学以点到点连接,北京大学使用POS以点到点与CERNET网络中心连接,CERNET通过租用专线以点到点与Internet连接。以上传输经过5个路由器。

3)静态设置

R1需要配置缺省路由,将下一跳路由器指定为R2。R2需要配置缺省路由,将下一跳路由器指定为R3。R3的缺省路由指向R4, 下一跳路由器指定为R2。配置静态路由,将数据分组转发给R1。化工大学访问Internet,转发路径R1-R2-R3-R4-R5;要访问化工大学,R5-R4-R3-R2-R1。
R1:
ip route 0.0.0.0 | 0.0.0.0 | 222.112.41.73
R2:
ip route 0.0.0.0 | 0.0.0.0 | 222.112.37.2
ip route 59.65.96.0 | 255.255.240.0 | 222.112.41.74
R3:
ip route 0.0.0.0 | 0.0.0.0 | 222.112.61.33 |
ip route 59.65.96.0 | 255.255.240.0 | 222.112.37.1 |
R4:
ip route 0.0.0.0 | 0.0.0.0 | 144.232.9.53 |
ip route 59.65.96.0 | 255.255.240.0 | 222.112.61.34 |

4)配置方法与步骤

全局模式下,ip route配置静态路由,no ip route删除静态路由。ip route<目的网络地址><子网掩码><下一跳路由器IP地址>。
Router (config) #ip route 59.65.96.0 255.255.240.0 222.112.37.1
Router (config) #

二. 动态路由协议配置

1. RIP动态路由协议的配置

用路由选择算法度量权值、自动计算最佳路径、建立路由表.只依据路由器跳数决定最佳路径,不考虑带宽、延时。

1)基本配置

启用并进入协议,设置参与RIP协议的网络地址。根据IP地址确定掩码,不需要给定掩码。

在全局配置模式下
Router (config) #router rip
Router (config-router) #network 159.105.0.0
Router (config-router) #network 212.112.7.0
Router (config-router) #exit
Router (config) #exit
Router #

RIP路由协议的配置信息如下:

router rip
network 159.105.0.0
network 212.112.7.0
!

2)高级配置

a.被动接口

指定接口上抑制路由更新,阻止更新报文通过接口,使用passive-interface指定一个路由器接口为被动接口。

在全局配置模式下
Router (config) #router rip
Router (config-router) #passive-interface ethernet 0
Router (config-router) #exit
Router (config) #exit
Router #

RIP路由协议的配置信息如下:

router rip
passive-interface Ethernet0
network 159.105.0.0
network 212.112.7.0
!

b. 路由过滤

指定接口上,既过滤进入(接收)的更新信息,也过滤输出(发送)信息。使用distribute-list命令。

在全局配置模式下
Router (config) #access-list 12 deny any
Router (config-router) #router rip
Router (config-router) #distribute-list 12 in ethernet0
Router (config-router) #end
Router #

c. 管理距离

AD是测量路由可信度的值,值越小,可信度越高。RIP缺省AD值120。distance命令提高或降低可信度,有效距离值1~255。

在全局配置模式下
Router (config) #router rip
Router (config-router) #distance 50
Router (config-router) #exit
Router (config) #exit
Router #

d. 定义邻居路由器

使用neighbor命令指定邻居,单播发送更新

在全局配置模式下
Router (config) #router rip
Router (config-router) #neighbor 202.112.7.2
Router (config-router) #exit
Router (config) #end
Router #

RIP版本,RIP1,RIP2。
RIP2支持可变长掩码,多点广播路由更新,路由更新认证。

2. OSPF动态路由协议的配置

1)特点

收敛速度快、路由汇聚使表变小、支持可变长掩码VLSM、 不采用广播报文而是组播报文。

2)区域ID

32位无符号数值,0~4294967295。十进制整数表示形式,2216169484。点分十进制数表示形式,132.24.16.12。0或0.0.0.0,骨干区域。

3)基本配置

启用并运行OSPF进程,配置路由器所属区域、区域范围、区域内参与OSPF路由的网址。使用router osfp <process ID>,PID:1~65535。
network ip <子网号> <wildcard-mask> area <区域号>定义OSFP的子网地址。
area <区域号> range <子网地址> <子网掩码> 定义聚合。

a. 使用network命令定义参与OSPF的子网地址。

全局配置下

① 单个IP地址参与OSPF

Router (config) #router ospf 63
Router (config-router) #network 131.107.25.1 0.0.0.0 area 0
Router (config-router) #exit
Router (config) #exit
Router #

② 网络地址参与OSPF

Router (config) #router ospf 63
Router (config-router) #network 133.181.0.0 0.0.255.255 area 0
Router (config-router) #exit
Router (config) #exit
Router #

b. 使用area range命令定义参与OSPF的子网地址。

Router (config) #router ospf 63
Router (config-router) #area 0 range 212.37.123.0 0.0.255.255.255.0
Router (config-router) #exit
Router (config) #exit
Router #

4)参数配置

a. 配置被动接口

与RIP相同,passive-interface接口。

① 路由器配置命令

Router (config) #router ospf 63
Router (config-router) #passive-interface ethernet 0
Router (config-router) #end
Router #

② 第三层交换机命令

Router (config) #router ospf 63
Router (config-router) #passive-interface vlan37
Router (config-router) #end
Router #

b. 配置路由过滤

与RIP相同
Router (config) #access-list 12 deny any
Router (config) #router ospf 63
Router (config-router) #distribute-list 12 in serial 0
Router (config-router) #end
Router #

c. 配置管理距离

与RIP相同,测量可信度,1~255。缺省AD值110,distance改变AD值,调整可信度。

Router (config) #router ospf 63
Router (config-router) #distance 10
Router (config-router) #end
Router #

d. 引入外部路由

OSPF配置模式下,redistribute配置引入外部路由。

① 花费值metric

全局配置下
Router (config) #router ospf 63
Router (config-router) # redistribute metric 100
Router (config-router) #end
Router #

② 缺省的标记值

全局配置下
Router (config) #router ospf 63
Router (config-router) # redistribute tag 100
Router (config-router) #end
Router #

③ 缺省的外部路由类型

Router (config) #router ospf 63
Router (config-router) # redistribute connected metric-type 1 subnets
Router (config-router) #end
Router #

5) OSPF路由协议配置信息

a. 路由器的OSPF路由协议

router ospf 63
area 0 range 166.105.0.0 255.255.0.0
area 0 range 212.112.7.0 255.255.255.0
redistribute connected metric-type 1 subnets
passive-interface FastEthernet2/0
passive-interface FastEthernet2/1
passive-interface FastEthernet2/2
passive-interface FastEthernet2/3
passive-interface FastEthernet2/4
passive-interface FastEthernet2/5
passive-interface GigabitEthernet4/0
passive-interface GigabitEthernet4/1
passive-interface GigabitEthernet6/1
network 166.105.0.0 0.0.255.255 area 0
network 212.112.7.0 0.0.0.255 area 0

b. 第三层交换机OSPF路由协议


router ospf 63
log-adjacency-changes
area 0 range 166.105.0.0 255.255.0.0
redistribute connected metric-type 1 subnets
passive-interface Vlan37
passive-interface Vlan38
passive-interface Vlan39
passive-interface Vlan40
passive-interface Vlan41
passive-interface Vlan42
network 166.105.0.0 0.0.255.255 area 0
!


习题7:考查路由协议配置

习题7-1
习题7-2

解析7:题干要求过滤g0/1输出的路由更新信息,即阻止更新报文通过接口,因此选用高级配置的被动接口,其防止端口发送路由信息。
Router (config) #router rip
Router (config-router) #passive-interface g0/1
且只有输入子网的信息,即213.33.56.0,故选C。

 

习题8:考查静态路由协议

如下图所示,某园区网用10Gbps的POS技术与Internet相连,POS接口的帧格式是SDH。园区网内部路由协议采用OSPF,园区网与Internet的连接使用静态路由协议。


习题8

请阅读以下R3的部分配置信息,并补充空白处的配置命令或参数,按题目要求完成路由器的配置。
R3的POS接口、OSPF和缺省路由的配置信息如下:
Router-R3 #Configure termina1
Router-R3 (Config) #
Router-R3 (Config) #interface pos3/0
Router-R3 (Config-if) #description To Internet
Router-R3 (Config-1f) #bandwidth 10000000
Router-R3 (Config-if) #ip address 202.112.8. 198 255. 255. 255. 252
Router-R3 (Config-if) #crc 32
Router-R3 (Config-if) #pos [ 6 ] sdh
Router-R3 (Config-if) #no ip directed-broadcast Router-R3 (Config-if) #pos f1ag [ 7 ]
Router-R3 (Config-if) #no shutdown
Router-R3 (Config-if) #exit
Router-R3 (Config) #[ 8 ] 65
Router-R3 (Config-router) #network 128.58.0.0 [ 9 ] area 0
Router-R3 (Config-router)#redistribute Connected metric-type 1 subnets
Router-R3 (Config-router)#area 0 range 128.58.0.0 255. 255. 128.0
Router-R3 (Config-router) #exit
Router-R3 (Config) #ip route [ 10 ]
Router-R3 (Config) #exit
Router-R3 #

解析8:【6】广域网配置POS接口,可选crc校验位是16和32。可选的帧格式(framing)是sdh和sonet;
【7】pos flag s1 s0数值,当s1 s0=00时,表示sonet的帧。当s1 s0=10(十进制2)时,表示SDH的帧。故本题应填s1 s0 2;
【8】根据路由器配置OSPF协议,在全局配置模式下,使用"router ospf <Process ID>命令可启动OSPF进程,故本格填写router ospf;
【9】在路由器OSPF配置模式下,使用“network ip<子网号><wildcard-mask> area <区域号>" 命令定义OSPF子网地址,或使用”area <区域号> range <子网地址> <子网掩码>"命令定义某一特定聚合,在“network"命令中的”<wildcard-mask>是子网掩码的反码,即反掩码。由命令行“area 0 range 128.58.0.0 255. 255. 128.0”可知,子网掩码为255.255.128.0,故反码为0.0.127.255。故此处填0.0.127.255。
【10】在全局配置模式下,使用"ip route"命令配置静态路由,使用"no ip route"命令删除静态路由。命令格式:ip route<目的网络地址><子网掩码><下一跳路由器的IP地址>,故此格为0.0.0.0 0.0.0.0 202.112.8.197。

 
习题9:考查OSPF路由协议配置

某园区网采用OSPF路由协议,参与OSPF的网络地址是169.111.0.0/16,Cisco路由器的正确配置是______。

A.Rounter(config)#router ospf 63
Rounter(config-router)#network 169.111.0.0 0.0.0.0 area 0
Rounter(config-router)#area 0 range 169.111.0.0 255.255.0.0
B.Rounter(config)#router ospf 63
Rounter(conng-router)#network 169.111.0.0 255.255.0.0 area 0
Rounter(config-router)#area 0 range 169.111.0.0 255.255.0.0
C.Rounter(config)#router ospf 63
Rounter(config-router)#network 169.111.0.0 0.0.255.255 area 0
Rounter(config-router)#area 0 range 169.111.0.0 255.255.0.0
D.Rounter(config)#router ospf 63
Rounter(config-router)#network 169.111.0.0 0.0.255.255 area 0
Rounter(config-router)#area 0 range 169.111.0.0 0.0.255.255

解析9:在全局配置模式下,使用“router ospf<Process ID>”命令,启动OSPF进程;在路由器的OSPF配置模式下,使用“network ip<子网号><wildcard-mask>area<区域号>”命令定义参与OSPF的子网地址,或使用“area<区域号>range<子网地址><子网掩码>”命令定义某一特定范围子网的聚合。由于network命令中的<wildcard-mask>是子网掩码的反码。参与OSPF的网络地址的子网掩码为255.255.0.0,故反码为0.0.255.255。而第三行要使用子网掩码,是255.255.0.0,故选择C。

 

习题10:考查静态路由配置

如下图所示,某校园网使用10Gbps的POS技术与CERNET相连,POS接口的帧格式使用SDH,Rl和R2之间使用静态路由。

习题10

请阅读以下Rl和R2关于POS接口和静态路由的配置信息,并补充空白处的配置命令或参数,按题目要求完成路由器的相关配置。

R1的POS接口配置如下:
Router-R1#configure terminal
Router-HI(config)#
Router-R1(config)#interfacepos4/10
Router-HI(config-if)#bandwidth【6】
Router-HI(config-if)#ipaddress203.22.76.2255.255.255.252
Router-HI(config-if)#crc32
Router-HI(config-if)#pos framing sdh
Router-R1(config-if)#no ip directed-broadcast
Router-H1(config-if)#pos flag【7】
Router-HI(config-if)#no shutdown
Router-HI(config-if)#exit
Router-HI(config)# 进入

R1的静态路由配置如下:

Router—Rl (config)#ip route【8】【9】203.22.76.1

R2的静态路由配置如下:
Router-R2(config)#ip route 0.0.0.00.0.0.0【10】

解析10:【6】带宽单位为Kbps,当带宽为10Gbps时,应转换为10000000bps;
【7】使用的帖格式为SDH,故pos flag为s1 s0 2;
【8】【9】在全局模式下,使用“ip route"命令来配置静态路由,使用”no ip route"命令来删除静态路由配置。命令格式为“ip route <目的网络地址> <子网掩码> <下一跳路由器的IP地址>"。路由器R1需要将目的网络为189.93.0.0/16的数据转发到路由器R2的203.22.76.1的端口。对应的route命令为"ip route 189.93.0.0 255.255.0.0 203.22.76.1的端口。故此两格填189.93.0.0和255.255.0.0。
【10】R2应填可以使用的第一个IP地址,为203.22.76.2。

 
以上,基本完成了第7章,路由器及其配置的构建。

推荐阅读更多精彩内容