安装cocoa pods失败,因为ruby版本过低的解决方法+ (void) {升级ruby}

需要配置cocoapods

命令行中显示:$ sudo gem install -n /usr/local/bin cocoapods

ERROR:  Error installing cocoapods:

activesupport requires Ruby version >= 2.2.2.

查看ruby版本后发现版本过低

$ ruby -v

ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin15]

那么你很幸运看到这篇文章,下边就来带你解决它吧~(总共分两步,  1升级ruby .  

  2安装cocoa pods)

1升级ruby傻瓜式的步骤:

1、安装 RVMRVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset)

$ curl -L get.rvm.io | bash -s stable  

等待一段时间后就可以成功安装好 RVM。(等着就好了,不到10秒吧.)

$ source ~/.bashrc  

$ source ~/.bash_profile 

 测试是否安装正常,(以上两个命令行敲了不会显示什么,但是需要敲)

rvm -v  

显示版本,会出现下边的样子(当然版本会由于时间的关系显示的不一样,下边的除了版本数不一定一样,其他的都是套路)

rvm 1.27.0 (latest) by Wayne E. Seguin, Michal Papis[https://rvm.io/]

2、用RVM升级Ruby

主要是第五行,看一下当前的版本有哪些?然后第七行安装个版本高点的(老板,来个2.3的)~

当然如果你看到这篇文章的时候版本可能会更高,你就别选2.3的了,版本能多高就多高吧少年.

#查看当前ruby版本

$ ruby -v

ruby 2.0.0

#列出已知的ruby版本

$ rvm list known

#安装ruby 1.9.3

$ rvm install 2.3

安装完成会显示这个:(一些绿色的代码,大概不到30行吧.最后一行会显示下边的内容,表示你安装成功了2.3版本)

Install of ruby-2.3.0 - #complete

Ruby was built without documentation, to build it run: rvm docs generate-ri

安装完成之后ruby -v查看是否安装成功。

(显示下边这个套路的话你就成功了,少年~,基本都会成功的.注意安装过程中不要拔网线...)

zhao95:~ zhao95outlook.com$

zhao95:~ zhao95outlook.com$ ruby -v

ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin15]

好了,ruby安装完了.

下边跟着命令行敲一遍就好了.

2安装cocoa pods

1.先升级Gem(可以省略)

sudo gem update --system

2.切换cocoapods的数据源

【先删除,再添加,查看】

gem source --remove https://rubygems.org/

gem source -a https://ruby.taobao.org/

gem source -l

3.安装cocoa pods  (下边随便选一个就好了,选完了需要输入你的账户密码的)

zhao95:~ zhao95outlook.com$ sudo gem install cocoapods

Password:

sudo gem install cocoapods

或者(如10.11系统)sudo gem install -n /usr/local/bin cocoa pods

(当你可以再次输入的时候就需要配置仓库了)

4.设置pod仓库

pod setup

zhao95:~ zhao95outlook.com$ pod setup

Setting up CocoaPods master repo

这时候我们会卡在这个步骤

其实,该情况也许并非真的卡住,下面给出两种解决方案。

方案1:

进入终端目录,输入ls -a可看到隐藏的pod文件夹,输入cd .cocoapods进入pod文件夹,然后输入du -sh即可看到repos文件夹的容量,隔几秒执行一下该命令,可看到repos的容量在不断增大,待容量增大至300+M时,说明,repos文件夹索引目录已安装完毕。此时,pod功能即可正常使用。

方案2:

通过方案1,我们知道在pod setup过程中,pod其实是在安装第三方库的索引目录,因此我们可以直接从githups上下载索引目录拷进repos文件夹。

前往https://github.com/CocoaPods/Specs,下载该索引,然后拷进repos文件夹。目录结构如下图所示:

图片示例


完全退出终端,重启终端,pod功能即可正常使用。

CocoaPods 1.1.0.beta.1 is available.

To update use: `sudo gem install cocoapods --pre`

[!] This is a test version we'd love you to try.

For more information, see https://blog.cocoapods.org and the CHANGELOG for this version at https://github.com/CocoaPods/CocoaPods/releases/tag/1.1.0.beta.1

Setup completed

(上边是下载完的样子) 【如果有版本号,则说明已经安装成功】

pod --version

6.利用cocoapods来安装第三方框架

01 进入要安装框架的项目的.xcodeproj同级文件夹

02 在该文件夹中新建一个文件podfile (pod init)

03 在文件中告诉cocoapods需要安装的框架信息

a.该框架支持的平台

b.适用的iOS版本

c.框架的名称

d.框架的版本

7.安装

pod install

pod update --no-repo-update

8.说明

platform :ios, '7.0' 用来设置所有第三方库所支持的iOS最低版本

pod 'SDWebImage','~>3.7.5' 设置框架的名称和版本号

版本号的规则:

'>1.0'    可以安装任何高于1.0的版本

'>=1.0'  可以安装任何高于或等于1.0的版本

'<1.0'    任何低于1.0的版本

'<=1.0'  任何低于或等于1.0的版本

'~>0.1'  任何高于或等于0.1的版本,但是不包含高于1.0的版本

'~>0'    任何版本,相当于不指定版本,默认采用最新版本号

9.使用pod install命令安装框架后的大致过程:

01 分析依赖:该步骤会分析Podfile,查看不同类库之间的依赖情况。如果有多个类库依赖于同一个类库,但是依赖于不同的版本,那么cocoaPods会自动设置一个兼容的版本。

02 下载依赖:根据分析依赖的结果,下载指定版本的类库到本地项目中。

03 生成Pods项目:创建一个Pods项目专门用来编译和管理第三方框架,CocoaPods会将所需的框架,库等内容添加到项目中,并且进行相应的配置。

04 整合Pods项目:将Pods和项目整合到一个工作空间中,并且设置文件链接。

卸载:sudo gem uninstall cocoapods

常见错误:

[!] /usr/bin/git pull --ff-only

原因: Cocoapods的分支不支持当前最新的Xcode版本

解决办法: 删除master分支 重新建立新的分支,然后重新设置仓库即可

sudo rm -fr ~/.cocoapods/repos/master

pod setup

推荐阅读更多精彩内容