解决macOS 10.15 软件提示损坏/无法验证开发者等问题

在macOS 10.15发布之后,苹果进一步提升了系统安全性,加强了软件安全性验证过程,这也导致很多用户升级之后,部分第三方软件尤其是破解版软件打不开,提示“XXX已损坏,无法打开”、“无法验证开发者”等问题。

起初很多人会以为是文件真的损坏了,重复试了好几次之后仍然反复出现这样的情况。其实,解决这个问题只要一段代码就可以。

当然,首先需要开启安全性与隐私中允许从任何来源下载APP,这个在macOS 10.15之前版本可以解决几乎所有第三方软件的问题,因此大部分用户应该是已经开启过了的,没有开启的话,需要在终端执行以下代码:

sudo spctl --master-disable

执行需要输入密码,注意输入的密码不会显示,输入完毕直接“Enter”就可以了,在安全性与隐私就可以看到已选择“任何来源”一项。

在macOS 10.15系统中这些仍然不能解决“文件损坏/无法验证开发者”,需要再执行一段代码:

sudo xattr -r -d com.apple.quarantine /XXX/XXX.app/

其中/XXX/XXX.app/需要替换为你所要打开的软件的位置,有一个比较简单的方法是,先在终端输入前半段sudo xattr -r -d com.apple.quarantine(最后保留一个空格),然后将所要执行的软件拖入终端,就可以在后面自动填入该软件的地址。

直接按“Enter”执行,输入密码即可。

一系列操作结束后,你就会发现原本打不开的软件现在终于可以正常使用了。