STM32调试器配置异常导致的问题与解决方法(一)

前些天整理开发板,找出了一个8年前的103的板子,上电后LED闪灯可以正常跑起来,看了看当时配套的例程,还是库函数的时代,心想用CUBE重写一个玩玩吧,STM32CubeMX配置如下:

(图一)

将PB8配置成输出口、时钟为72MHz,生成KEIL工程,编译,用ST-LINK下载到目标板上,闪灯ok了;但修改代码后再次下载,杯具了,下载失败!


图二
(图三)

检查了板子、ST-LINK、芯片等硬件环境,一切ok,为什么下载会失败呢?----第一次下载为什么正常呢?

注意看图一中,对于STM32F1芯片,STM32CUBE管脚配置中的SYS选项,默认的是 No Debug,就是这个选项造成板子debug(以及下载)失效!

检查cube生成的代码,在文件 stm32f1xx_hal_msp.c 中,有下面代码:

                              /**DISABLE: JTAG-DP Disabled and SW-DP Disabled     */

                               __HAL_AFIO_REMAP_SWJ_DISABLE();

这一句实际就是对应图一中SYS配置选项的, __HAL_AFIO_REMAP_SWJ_DISABLE()是一个宏定义,在文件 stm32f1xx_hal_gpio_ex.h 中:

/**

  * @brief Disable the Serial wire JTAG configuration

  * @note  DISABLE: JTAG-DP Disabled and SW-DP Disabled

  * @retval None

  */

#define __HAL_AFIO_REMAP_SWJ_DISABLE()  do{ CLEAR_BIT(AFIO->MAPR, AFIO_MAPR_SWJ_CFG);        \

                                            SET_BIT(AFIO->MAPR, AFIO_MAPR_SWJ_CFG_DISABLE);  \

                                          }while(0U)

看它的注释知道,这个宏把SW(就是ST-LINK了)和JTAG都给禁用了,具体的操作是对AFIO复用功能的寄存器MAPR的某些位做了设置,使得MCU失能了debug功能(F0没有这个MAPR寄存器,F0不支持JTAG,如果SWDIO或SWCLK管脚被配置成普通IO也会引起debug异常,见后文)。CUBE这样做的目的,是为了所谓优化管脚配置,空余出更多的pin给用户使用,但好心没办成好事,CUBE把禁用debug当成了默认配置!

知道了问题所在,回到CUBE中修改:

(图四)

重新生成代码,查看 stm32f1xx_hal_msp.c 文件,之前的宏  __HAL_AFIO_REMAP_SWJ_DISABLE() 变成了:

                              /**NOJTAG: JTAG-DP Disabled and SW-DP Enabled   */

                               __HAL_AFIO_REMAP_SWJ_NOJTAG();

查它的定义:

/**

  * @brief Enable the Serial wire JTAG configuration

  * @note  NOJTAG: JTAG-DP Disabled and SW-DP Enabled

  * @retval None

  */

即:JTAG的SW调试方式是使能的(但JTAG debug是失能的)。

编译后,下载,仍然失败!出错提示跟图二、图三一样!进到KEIL工程配置的Debug选项,看到目标板的MCU没有被识别到:


图五

原因很简单:目标板现在是上电状态,MCU在正常工作,而MUC的启始代码中有禁用debug的语句,MCU一直处在禁用debug的状态,所以下载、debug都是失败的!

想要正常下载代码或进行debug,有2个方法可以考虑:擦除MCU中FLASH里的代码;或,把ST-LINK的“4线调试”改为规范的“5线调试”,即增加复位信号线。为了擦除代码,显然使用ST-LINK是不行的,因为现在ST-LINK根本连不上目标板,可以采用STM32串口下载的方法,比较麻烦,具体操作请百度,这里重点说一下第二种方法。

对于标准的ST-LINK接口,实际上是5根线:VCC,GND, SWDIO, SWCLK, nRST。最后一个是复位信号,跟MCU的RESET管脚相连接,但大家实际使用时,一般都是用前4根线,省掉了复位线,大多数情况下这样使用也是没有问题的,因为SWD调试协议里,通过数据线SWDIO的特殊数据序列可以“”软复位“MCU,然后进入debug状态。但现在的情况是,MCU一上电就立即运行代码、禁用了debug(如果启动代码中配置了SWDIO管脚为输入输出功能,也会是类似的情况),来自SWDIO的软复位来不及动作,实际上就是ST-LINK未能正确reset MCU。为了使ST-LINK能reset MCU,这时第5根线nRST就派上用场了。

把ST-LINK的复位pin与目标板MCU的reset管脚相连,KEIL中再次打开程配置的Debug选项,可是看到还是如图五所示的:无目标MCU连接!别急,还有重要的一步配置需要做:

图六

Debug配置卡里,Connect项目,要选择成 under Reset (默认为Normal)!就是说:使用硬件复位方式!点击选项卡的确定,然后再次进入Debug选项卡,这次看到连接目标板成功了。

此时再次下载或进入调试,不再出现异常提示了。

小结:

1)对于STM32的板子,遇到用KEIL下载失败,或debug失败,如果检查了硬件环境都没有问题,那么问题可能出在MCU的debug配置上,这个MCU中的代码可能禁用了debug,或者跟debug有关的pin(SWDIO、SWCLK等)被配置成了普通IO。

2)ST-LINK常见的4线接法,大多数情况下这样使用是没有问题的;如果遇到了debug功能失效,要考虑把第五根线,即复位线,接上去。

3)使用ST-LINK复位线时,别忘了在KEIL的debug配置卡中更改Connect方式为under Reset;否则将仍旧连接不上目标板。

结束之前,可能有聪明的同学要问了:既然STM32把跟debug有关的pin都定义成了复用功能,那怎么才能把这些pin既可以用来调试、又可以当GPIO使用呢?请见下文分解:

STM32调试器配置异常导致的问题与解决方法(二)

推荐阅读更多精彩内容