解决Android Studio4.1.1不适配ButterKnife的问题

一、Android Studio4.1.1不适配ButterKnife

1.重新下载Android ButterKnife Injections

image.png

2.删除plugins的其他ButterKnife文件

image.png

AppData是隐藏文件夹、User是电脑的名字、Users在C盘中的用户

3.重启IDE

4.进行build.gradle(Module:app)配置

android {  
  ...
  compileOptions {  
    sourceCompatibility JavaVersion.VERSION_1_8
    targetCompatibility JavaVersion.VERSION_1_8
  } 

dependencies {
    implementation 'com.jakewharton:butterknife:10.2.3'
    annotationProcessor 'com.jakewharton:butterknife-compiler:10.2.3'
}

5.Sync gradle