JDK16使用lombok报错

起因是因为要学习Spring WebFlux,尔后更新本地JDK版本为16。

一、项目启动报错

错误提示如下:

java: java.lang.IllegalAccessError: class lombok.javac.apt.LombokProcessor (in unnamed module @0x60ddd074) cannot access class com.sun.tools.javac.processing.JavacProcessingEnvironment (in module jdk.compiler) because module jdk.compiler does not export com.sun.tools.javac.processing to unnamed module @0x60ddd074

二、基本解决办法

更新最新的lombok插件,目前我使用的是SpringBoot版本是2.5.0,所以Lombok版本得使用1.18.20。

        <dependency>
            <groupId>org.projectlombok</groupId>
            <artifactId>lombok</artifactId>
            <version>RELEASE</version>
            <scope>compile</scope>
        </dependency>

三、报错原因

JDK版本太高,lombok版本太低。新版本有风险,升级需谨慎。

推荐阅读更多精彩内容