iOS开发中cocoaPods的安装与问题的解决

<pre></code>
1.$ gem sources --remove https://rubygems.org/
//http必须带s
2.$ gem sources -a https://ruby.taobao.org/
为了验证你的Ruby镜像是并且仅是taobao,可以用以下命令查看:
$ gem sources -l
只有在终端中出现下面文字才表明你上面的命令是成功的:
*** CURRENT SOURCES ***

http://ruby.taobao.org/
接下来可以安装了
$sudo gem install cocoa pods

二、安装cocoaPods错误 --ruby的 版本低了
ERROR: Error installing cocoapods:
activesupport requires Ruby version >= 2.2.2.
解决方法:
$ruby -v 查看版本
先输入以下命令查看是否安装了rvm
$ rvm -v
command not found //表示没有,按下面安装

RVM的安装

//$cat ins|bash -s stable
curl -L get.rvm.io | bash -s stable

mac,

Thank you for using RVM!

We sincerely hope that RVM helps to make your life easier and more enjoyable!!!

~Wayne, Michal & team.

In case of problems: https://rvm.io/help and https://twitter.com/rvm_io
Upgrade Notes:

  • No new notes to display.
    表示镜像安装成功了

然后,载入 RVM 环境
$ source ~/.rvm/scripts/rvm
检验安装
$ rvm -v //会显示
rvm 1.27.0 (latest) by Wayne E. Seguin wayneeseguin@gmail.com, Michal Papis mpapis@gmail.com [https://rvm.io/]

用 RVM 安装 Ruby 环境
输入命令  
$ rvm install 2.2.2
慢慢等待,期间可能需要输入mac密码

RVM 装好以后,需要执行下面的命令将指定版本的 Ruby 设置为系统默认版本
$ rvm 2.0.0 --default

$ ruby -v //查看版本是否正确
接下来就是继续安装了
$ sudo gem install cocoapods

SVN 初始化项目

svn import /Users/userName/Desktop/项目 https://188.188.188.188/svn/SVN文件夹名称 --username=用户名 --password=密码 -m "初始化导入"

推荐阅读更多精彩内容