互联网中大约 62% 的网站将在 10 周之后处于危险之中

96
极小光 Db3aaf4f effd 43dc 9137 d6bf7f70211e
2018.10.22 16:35 字数 385

简评:因为非常受欢迎的PHP 5.x 分支将在年底无法接收安全更新。解决方法?当然是升级到 php7!

W3Techs 的统计数据显示,目前所有互联网站点中约有 78.9% 运行着 PHP,但是 2018 年 12 月 31 日,PHP 5.6.x 的安全支持将会正式停止,这标志着 PHP 5 正式退出历史舞台。

这意味着从明年(2019 年)开始,大约 62% 仍在运行 PHP 5.x 版本的互联网站点将无法接收其服务器和底层技术的安全更新,从而使数以亿计的网站暴露于严重的安全风险中。如果黑客在新年之后发现 PHP 中的漏洞,很多网站和用户都会面临风险。

如果有人发现自己在年底之后还在运行 PHP 5,那就问问自己:你觉得自己幸运吗?

PHP 社区早就已经知道这个截止日期了, 在 PHP 5.6 成为 2017 年春季使用最广泛的 PHP 版本之后,PHP 的维护人员意识到如果他们在 PHP 5.6 成为最受欢迎的 PHP 版本时停止安全更新将会是一场灾难 —— 所以他们将 EOL 日期扩展到了 2018年底。


原文链接:Around 62% of all Internet sites will run an unsupported PHP version in 10 weeks | ZDNet
推荐阅读:Github 升级到 Rails 5.2.1 了

极光日报
极光日报
55.1万字 · 38.7万阅读 · 1084人关注
每日为 Makers 导读 1-3 篇优质英文文章。 内容涉及:硅谷、科技、编程、设计、人工智能等相关领域。
Web note ad 1