关于cocopoads找不到最新版本的第三方问题

搜索不到最新的第三方框架(比如:官方SDKTZImagePickerController 1.7版本,pod的搜索出的是1.6,也更新不了)原因是本地索引文件需要更新;
例如:

pod search  MJExtension

结果如下:
CC0CBCDE36AAC2781BE56B355BB6A4B9.png

但是实际上这个库已经更新到3.0.15.1了

2ACA04AD3935BBB10B369AC5C8839CEF.png

参看链接
https://www.cnblogs.com/dwj97/p/7442682.html
1.可能是MAC Ruby版本太低了的原因
2.可能是Pod版本问题
我们更新下Ruby就好
操作如下即可解决你的问题

第一步:安装 Homebrew

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

第二步:通过 brew 安装 Ruby 最新版本

在命令行下依次执行以下命令,即可自动完成最新版本 Ruby 的安装:
brew update
brew install ruby

第三步:

1.先检查自己的Pod是否是最新的版本
➜  ~ pod --version  
如果不是最新的就要执行下面的命令更新升级你的Pod了
2.sudo gem install cocoapods --pre
切换源
3.gem sources --remove https://rubygems.org/
4.gem source -a https://gems.ruby-china.org
查看是否切换成功
5.gem source -l
如果是如下则切换成功

*** CURRENT SOURCES ***
 
https://ruby.taobao.org/
https://gems.ruby-china.org

升级cocoapods
sudo gem install -n /usr/local/bin cocoapods --pre 
但是有时候pod升到最新版本后我cd到工程文件下 pod install,发现还是没有更新最新的库。这时候需要更新本地Pod的索引文件
6.pod setup

通过 homebrew 安装 Ruby

我在这个链接上找到的资料可以参考https://brew.sh/index_zh-cn
https://www.cnblogs.com/dwj97/p/7442682.html
https://blog.csdn.net/qianyoucaicsdn/article/details/71455570
还有一种处理方法
https://blog.csdn.net/dkq972958298/article/details/53813662

推荐阅读更多精彩内容