/usr/local/bin/pod: /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby: bad inte...

通过cocoapods 更新库的时候,偶尔会遇到这样的错误,尤其是在系统升级之后。原因嘛,应该是系统升级引起的ruby 或者cocoapods版本的不适配造成的。

为了保证成功率,我同时也更新了brew。

bogon:~ wmy$ brew update

更新完brew之后,就可以更新ruby了,

bogon:~ wmy$ brew install ruby

完事儿之后,开始更新cocoapods了

bogon:~ wmy$ sudo gem install -n /usr/local/bin cocoapods

然后就可以使用cocoapods 愉快地玩耍了。当然,前提是你已经安装了cocoapods,

推荐阅读更多精彩内容