CocoaPods doesn't work after upgrading Mac OS X EI Capitain

今天使用cocaPods出现" The command path could not be resolved",由于Mac OS X EI Capitain 将pods的路径改了,具体操作:

1. sudo gem uninstall cocoapods

2. sudo gem install -n /usr/local/bin cocoapods

3. sudo chmod +rx /usr/local/bin/


出现错误:

Error fetching http://ruby.taobao.org/:

bad response Not Found 404 (http://ruby.taobao.org/specs.4.8.gz)

移除

gem sources --removehttp://ruby.taobao.org/

新增

gem sources -a https://ruby.taobao.org/

推荐阅读更多精彩内容