wxpython安装问题

ERROR: Could not find a version that satisfies the requirement six (from wxPython==4.0.0b2) (from versions: none)
ERROR: No matching distribution found for six (from wxPython==4.0.0b2)

解决步骤:
1.安装wxPython需要先安装好wheel,使用pip2 install whee -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com

2.安装了wheel之后还在报错,更换网络连接,安装成功 wxPython-4.1.0
但是出现报错信息
robotframework-ride 1.7.4.2 requires wxPython<=4.0.7.post2, but you'll have wxpython 4.1.0 which is incompatible

3.由上提示报错的信息可知robotframework-ride 1.7.4.2支持的是wxPython<=4.0.7.post2版本的,
(1)首先卸载之前安装的wxPython
pip uninstall wxpython
(2)再下载版本低于等于4.0.7.post2的wxPython
pip install wxPython-4.0.7 -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com

4,根据提示的错误信息
robotframework-ride 1.7.4.2 requires Pygments, which is not installed.
robotframework-ride 1.7.4.2 requires PyPubSub, which is not installed.
robotframework-ride 1.7.4.2 requires Pywin32, which is not installed.
进行依次安装
pip install Pygments -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com
pip install PyPubSub -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com
pip install Pywin32 -i http://pypi.douban.com/simple/ --trusted-host pypi.douban.com