vue 兼容低版本机型

低版本的安卓手机可能会白屏,是由新特性不支持引起的

解决代码es6新特性兼容问题
1,npm 安装

npm install babel-polyfill 
npm install es6-promise

2,main.js 引入

import 'babel-polyfill'

import Es6Promise from 'es6-promise'

require('es6-promise').polyfill()

Es6Promise.polyfill()

3.webpack.base.conf.js

module.exports = {
  context: path.resolve(__dirname, '../'),
  entry: {
    app: ['babel-polyfill','./src/main.js']
  },