老铁,是时候干掉 iOS8 了!

一. 背景

由于本期产品需求中有一个保存人员信息到通讯录的功能,因为这部分 iOS 8 使用到<AddressBook/AddressBook.h>库已经不维护了,iOS9+ 需要<Contacts/Contacts.h>库,因此如果需要继续适配 iOS8 的话,就要写对应的两套代码,查看了数据统计之后发现我们目前没有 iOS8 的用户,就不想感动自己继续适配 iOS8,因此总结了一下信息向leader申请干掉 iOS8

二. 总结内容如下

1. 苹果官方于今年6月份的 WWDC 上推出了 iOS11 系统,当时统计的各系统的数据占比如下:
  • iOS10 系统占比 89%
  • iOS9 系统占比 9%
  • 其他系统占比 2%

目前 iOS8 系统最多占比 2%,而且针对我们产品的目标人群:办公人士的低版本系统占比会更低

数据来源:https://developer.apple.com/support/app-store/

最新的只显示 iOS11和 iOS10了

2. 砍掉 iOS8 的好处

可以直接使用最低版本为 iOS9 的api,不需要一些额外的适配工作,提高项目稳定性,代码也会更加简洁

  • 比如有些场景使用 UIStackView,不需要进行额外的布局适配
  • 增强的UIKit动力学,如用于非矩形碰撞边界检测等
  • 新增NSDataAsset类,使得更加方便获取定制设备的内存和图形处理能力
  • 所有标准的UIKit控件翻转,能够支持从右到左的语言。此外,导航,手势,Collection View和TableViewCell的布局也适当地翻转
  • MapKit框架对功能进行了一些补充,比如支持查询公交的预计到达时间和公交路线、地图视图支持了3D天桥模式、注释可以完全定制
  • PassKit框架在Apple Pay支持Discover cards、借记卡和信用卡。
  • SFSafariViewController可以用来显示你的应用程序中的网页内容。它和safari共享Cookie和其他网站数据,并有许多的Safari浏览器的强大功能,如Safari自动填充和Safari阅读器。与Safari浏览器本身相比,SFSafariViewController UI是一个单一的Web页面,有一个完成按钮可以使用户回到应用程序中。
  • 如果您的应用程序显示的网页内容,但不自定义内容,可以考虑更换WKWebView或UIWebView为SFSafariViewController
  • HealthKitFramework对跟踪生殖健康和紫外线照射的等新领域的支持。
  • 使用AVPictureInPictureControllerAVPlayerViewController类,实现Picture in Picture功能。
  • FoundationFramework 中 Strings文件的上下文相关的可变宽度的字符串支持。
  • 对于 iPad,可以更方便地使用分屏多任务特性,如画中画视频播放等
  • 另外一些扩展也新增了一些特性
    更多详细 iOS9 新特性点击这里-官网说明
2. 可以在这里贴一下当前产品的统计数据,月活的 iOS8 用户占比,肯定很少
3. 以下为不同型号手机支持的最高系统版本:
  • iPhone 4 最高支持7.1.2
  • iPhone 4s 最高支持9.3.5
  • iPhone 5 最高支持10.3.3
  • iPhone 5c 最高支持10.3.3
  • iPhone 5s及以上都支持到 11.0
4. 以下为不同型号手机支持的最低系统版本:
  • iPhone 5 最低支持 6.0
  • iPhone 5c 最低支持 7.0
  • iPhone 5s 最低支持 7.0
  • iPhone 6 最低支持 8.0
  • iPhone 6s 最低支持 9.0
  • iPhone SE 最低支持 9.3
  • iPhone 7 最低支持 10.0
  • iPhone 8 及以上最低支持 11.0
5. 主要竞品的最低适配版本:
  • 钉钉 7.0 (钉钉的部门目标用户是餐饮等传统行业,用户 iPhone 系统版本应该会略低于普通互联网公司)
  • Slack 9.0 (Slack 创始团队就是一帮程序员,主要目标用户也是互联网小团队,适配版本高于其他一般 App 也是理所应当)
  • BearyChat 9.0(BearyChat的模式大部分与 Slack 类似,相当于国内的 Slack)
  • 企业微信 8.0
  • 美团大象 8.0
  • 纷享销客 8

按照以往的经验,一般的App 都是保持适配三个最新的系统版本(比如微信、淘宝、美团等是在去年年末抛弃了iOS7.0,注:去年推出了iOS10)

砍掉之后,iOS8 新老用户在appStore 只能搜索到支持 iOS8的最高版本,

6. 注意事项
  • 检查一下提醒升级及强制升级的相关参数,比如下版本不支持 iOS8 用户了,那么对于 iOS8 用户的升级提醒要屏蔽掉,并提前和 BS 同学确认相关问题
  • 对于可预见的接口需求上的改动、提前做好老版本的适配工作,即使某些功能不能正常使用也要做相应的屏蔽或者 PlaceHolder
  • 干掉 一个老版本 之后,可以查看下对应的警告,把该版本专门的适配代码也相应干掉;有些被弃用的api或枚举值也会报警告,最好进行相应更新
7. 去年今日:得知是最后一版适配 iOS8 的时候,高兴的像个三百斤的胖子
iOS7 适配比 iOS8 逆天多了

参考:
iOS9新特性-官方说明
iOS系统-官网统计

推荐阅读更多精彩内容