ius第三方源推荐—— 在centos 上用yum安装最新的包

centos 通常自带的yum源提供的各种软件包都是比较老的版本, 如果想用yum安装最新的软件,推荐第三源ius

sudo yum install https://centos7.iuscommunity.org/ius-release.rpm  # 安装源

# 查询目标软件
yum list git git\*u   # ius 通常会在高版本的软件名后面+‘u’

已安装的软件包
git2u.x86_64                    2.16.5-1.ius.centos7                     @ius   
可安装的软件包
git.x86_64                      1.8.3.1-14.el7_5                         updates

# 如果你已经装有低版本的git,你需要先remove (否则安装的时候会报错)
yum remove git

# 安装
yum install git2u  # 将安装2.0以上版本的git 

如果你不想先移除低版本再安装新版本, 想一次通过一个命令update,可以不可以呢?
由于软件包的名字已经重命名,所以不能用yum update,不过你可以使用插件yum replace plugin

# 首先得安装该插件
yum install yum-plugin-replace
yum replace php --replace-with php56u  # 一条命令就可以升级版本

原文链接:http://jiebaby.com/index.php/archives/42/

推荐阅读更多精彩内容