android-apt plugin is incompatible with the Android Gradle plugin. 异常

解决android-apt plugin is incompatible with the Android Gradle plugin. Please use 'annotationProcessor' configuration instead.问题

添加apt插件出现以下错误:

解决方法就是:使用annotationProcessor进行配置

1、将Project下的build.gradle中将对应插件的classpath注释掉

image.png

2、同时也将对应的app下的build.gradle下,用插件删除:


image.png

3、将依赖中的apt的改为annotationProcessor


image.png

改为
image.png

以上三步就解决问题,造成这个的原因是:Gradle3.X.X 后,不兼容android-apt插件生成编译时注解的方式,这也是就在AS3.0使用中遇到的问题;

推荐阅读更多精彩内容