Tensorflow执行pip升级安装的坑

Tensorflow是Google的深度学习框架,目前在工业界和学术界都很受欢迎。刚推出的时候,Tensorflow的安装和使用都非常麻烦。幸好迭代到目前,tensorflow(写作本文时最新版本为1.2.0)的安装已经非常简便了。

如果你的系统已经安装好了Anaconda(安装方式请参考《如何用Python做词云?》一文),则全新的Tensorflow安装,只需要执行一行语句:

pip install tensorflow 

完事大吉。

注意这里咱们讨论的是CPU版本。关于GPU版本的安装方法,请参考tensorflow 官方说明

但是,如果你之前安装过tensorflow的旧版本的话,有个坑请留意。

升级的时候,你采用的命令应该为:

pip install -U tensorflow 

我今天就是这样执行的,可惜会报错。

Collecting setuptools (from protobuf>=3.2.0->tensorflow)
 Downloading setuptools-36.0.1-py2.py3-none-any.whl (476kB)
 100% |████████████████████████████████| 481kB 61kB/s 
Installing collected packages: setuptools, protobuf, backports.weakref, tensorflow
 Found existing installation: setuptools 20.3
Cannot remove entries from nonexistent file /anaconda/lib/python2.7/site-packages/easy-install.pth

查询了一下,问题出在setuptools上。解决方法我参考了 这个帖子 。只需要执行一句话:

pip install -U -I setuptools

执行结果如下:

Collecting setuptools
 Using cached setuptools-36.0.1-py2.py3-none-any.whl
Installing collected packages: setuptools
Successfully installed setuptools-36.0.1

这样就可以彻底解决setuptools的麻烦。然后再执行:

sudo pip install -U tensorflow

一切顺利,1.2.0版本的tensorflow就安装上了。

1.0正式版后,Tensorflow 的API与之前版本比起来,更加简单易用。甚至还整合了keras模块。许多常用深度学习应用的代码,可以降低到之前版本的50%以下。

所以,Tensorflow的版本一定要及时更新。

祝深度学习之路愉快哦!

延伸阅读

如何用《玉树芝兰》入门数据科学?

数据科学相关文章合集(玉树芝兰)

作者信息

王树义,大学教师,终身学习者。稍微懂一点儿写作、演讲、Python和机器学习。欢迎微信关注并置顶我的公众号“玉树芝兰”(nkwangshuyi)。

推荐阅读更多精彩内容