Xcode10 运行libstdc++报错处理方案

和以前一样,新大版本的Xcode运行现有项目多多少少会报一定的错误,这次也不例外,Xcode10 版本运行现有项目报错最多的应该就是如图:

这个错误原因是因为iOS12.0中去掉了lstdc++.6.0.9.tbd动态库,如下图搜索便知:

# iOS12.0中全部采用libc++代替lstdc++的动态库(如下图),具体原因可以参考:

所以最简单解决该问题的方法就是从Xcode9.4中找到动态库lstdc++.6.0.9.tbd文件copy到Xcode10下就可以完美解决问题。或者用古老的办法将iOS12的DeviceSupport文件copy到Xcode9.4下也可以完美解决Xcode9.4运行iOS12的问题。

真机路径:/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/lib

模拟器:  /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/usr/lib

为了方便大家,在此提供lstdc++.6.0.9.tbd动态库文件下载 

libstdc++.6.0.9.tbd

推荐阅读更多精彩内容