×
广告

ubuntu16.04 安装docker-ce,解决libltdl7版本过低的问题。

96
Bryan_Chen
2017.07.07 10:44* 字数 196

遇到的问题:

按照docker官方安装教程,执行到:
sudo apt-get install docker-ce

安装失败,出现如下错误:

The following packages have unmet dependencies:
docker-ce : Depends: libltdl7 (>= 2.4.6) but it is not going to be installed
Recommends: aufs-tools but it is not going to be installed
Recommends: cgroupfs-mount but it is not installable or
cgroup-lite but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

如图:

image.png

此问题源于libltdl7版本过低,ubuntu16.04默认无更高版本。

解决办法:

搜索到libltdl7 2.4.6的包,下载:
wget http://launchpadlibrarian.net/236916213/libltdl7_2.4.6-0.1_amd64.deb

如图:

image.png

安装deb包:
sudo dpkg -i libltdl7_2.4.6-0.1_amd64.deb

如图:

image.png

再次安装docker-ce。
sudo apt-get install docker-ce

如图:

image.png
image.png
成功!
日记本
Web note ad 1