【Node.js】安装使用nvm管理nodejs版本

【Node.js】安装使用nvm管理nodejs版本

本文主要介绍mac/linux下如何安装nvm来管理nodejs版本


一、下载nvm安装

方式一:brew方式

1:brew list nvm 命令检测是否安装nvm,输入以下提示时为未安装:
Error: No such keg: /usr/local/Cellar/nvm
或者可以使用nvm --version命令来判断
2:brew install nvm 命令安装nvm
3:在shell的配置文件(~/.bashrc, ~/.profile, or ~/.zshrc)中添加内容:

修改文件:
vi ~/.bash_profile
添加内容:
# For NVM
export NVM_DIR=~/.nvm

4:source $(brew --prefix nvm)/nvm.sh 命令生效刚刚的修改

PS:使用brew安装nvm会出现iterm等终端工具退出重新打开后无法使用nvm命令的情况,什么问题呢:主要是brew安装nvm后~/.nvm文件夹下无nvm.sh和nvm.exec文件;所以我们只有copy一下这两个文件或者使用下面的一种方式来安装。

方式二:

1:安装
cURL:

curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.33.8/install.sh | bash

or Wget:

wget -qO-https://raw.githubusercontent.com/creationix/nvm/v0.33.8/install.sh | bash

该脚本将nvm存储库克隆到~/.nvm 并将源代码行添加到您的概要文件 (~/.bash_profile, ~/.zshrc, ~/.profile, or ~/.bashrc). -- 意思就是自动帮你添加了;只需要cat ~/.bash_profile查看一下是否有以下代码就ok

export NVM_DIR="$HOME/.nvm"

[ -s "$NVM_DIR/nvm.sh" ] && . "$NVM_DIR/nvm.sh" # This loads nvm

2:验证
nvm --version 看看是否可以使用,显示版本号的话就已经安装成功了;
如果没有显示,则需要source ~/.bash_profile一下然后就ok

二、使用nvm安装nodejs

查看nvm并安装nodejs

nvm --version // 查看nvm版本
nvm install latest // 下载最新的 node 版本
nvm ls-remote // 查看远程已经存在的版本(可能会很慢,请耐心等待)
nvm install v8.9.0 // 下载指定版本nodejs
nvm install v8.9.0 32 // 默认是64位,32位需指定
nvm current // 当前使用版本
nvm use v8.9.1 // 使用指定版本
nvm list // 查看已经安装的nodejs版本
node --version // 查看nodejs版本

更多命令使用命令 nvm 查看

三、配置npm及使用

默认的 npm registry 会很慢,这时候我们一般改为淘宝的镜像,下面是使用方法:
淘宝 npm 地址: http://npm.taobao.org/

1:临时使用:

npm --registry https://registry.npm.taobao.org install express

2:永久使用:

npm config set registry https://registry.npm.taobao.org

配置后可通过下面方式来验证是否成功

npm config get registry
或 
npm info express

3:通过cnpm使用

npm install -g cnpm --registry=https://registry.npm.taobao.org

使用

cnpm install express

到此 nvm/node 就已经安装成功,用起来吧!

PS:在用 Vue.js 构建大型应用时推荐使用 NPM 安装,NPM 能很好地和诸如 Webpack 或 Browserify 模块打包器配合使用。Vue.js 也提供配套工具来开发单文件组件。

官方安装命令:

# 最新稳定版
$ npm install vue

如果安装出现以下问题:

这里写图片描述

将提示目录下的文件 /Users/yclimb/package-lock.json 修改为 package.json

mv package-lock.json package.json

然后重新执行安装vue命令就可以了。

扫描下面二维码,关注我的公众号哦!!!


关注我的公众号

推荐阅读更多精彩内容