PAT Advanced 1035. Password (20) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

To prepare for PAT, the judge sometimes has to generate random passwords for
the users. The problem is that there are always some confusing passwords since
it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero)
from O (o in uppercase). One solution is to replace 1 (one) by @, 0
(zero) by %, l by L, and O by o. Now it is your job to write a
program to check the accounts generated by the judge, and to help the juge
modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer
N ( \le 1000 ), followed by N lines of accounts. Each account consists
of a user name and a password, both are strings of no more than 10 characters
with no space.

Output Specification:

For each test case, first print the number M of accounts that have been
modified, then print in the following M lines the modified accounts info,
that is, the user names and the corresponding modified passwords. The accounts
must be printed in the same order as they are read in. If no account is
modified, print in one line There are N accounts and no account is modified
where N is the total number of accounts. However, if N is one, you must
print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

思路

将密码中的几个字符转化为另一个字符,很简单的题目。

我的具体做法是边读边改,并且将无需更改的密码首字符置为'\0',就是当做标记以便区分。后面输出就容易了。

代码

最新代码@github,欢迎交流

#include <stdio.h>

int main()
{
    int N, count = 0, modified;
    char username[1000][11], password[1000][11];

    scanf("%d", &N);
    for(int i = 0; i < N; i++)
    {
        modified = 0;
        scanf("%s %s", username[i], password[i]);
        for(char *p = password[i]; *p; p++)
        {
            switch(*p)
            {
                case '1': *p = '@'; modified = 1; break;
                case '0': *p = '%'; modified = 1; break;
                case 'l': *p = 'L'; modified = 1; break;
                case 'O': *p = 'o'; modified = 1; break;
                default: break;
            }
        }
        if(modified)
            count++;
        else  /* mark unmodified password */
            password[i][0] = '\0';
    }

    if(count)
    {
        printf("%d\n", count);
        for(int i = 0; i < N; i++)
            if(password[i][0] != '\0')
                printf("%s %s\n", username[i], password[i]);
    }
    else
    {
        printf("There %s %d %s and no account is modified",
            N > 1 ? "are" : "is", N, N > 1 ? "accounts" : "account");
    }

    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 158,560评论 4 361
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 67,104评论 1 291
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 108,297评论 0 243
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 43,869评论 0 204
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 52,275评论 3 287
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 40,563评论 1 216
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 31,833评论 2 312
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 30,543评论 0 197
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 34,245评论 1 241
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 30,512评论 2 244
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 32,011评论 1 258
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 28,359评论 2 253
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 33,006评论 3 235
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 26,062评论 0 8
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 26,825评论 0 194
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 35,590评论 2 273
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 35,501评论 2 268

推荐阅读更多精彩内容

  • NAME dnsmasq - A lightweight DHCP and caching DNS server....
    ximitc阅读 2,651评论 0 0
  • By clicking to agree to this Schedule 2, which is hereby ...
    qaz0622阅读 1,311评论 0 2
  • pyspark.sql模块 模块上下文 Spark SQL和DataFrames的重要类: pyspark.sql...
    mpro阅读 9,391评论 0 13
  • 【知】在没钱的时候,把勤舍得出去,钱就来了,就叫天道酬勤。在有钱的时候,把钱舍得出去,人就来了,这叫财散人聚。当有...
    真承阅读 175评论 0 0
  • 交互设计主要解决的是结构层和框架层的问题,当然并不是说别的层次的问题就与交互设计无关了,交互设计师经常会参与到范围...
    Enya年阅读 562评论 0 2