解决pip使用异常 No module named 'pip'

安装Scrapy的时候出现pip版本过低,不能安装,提示建议我们升级pip
,一般情况下我们会使用

pip install - upgrade pip3

但这样会出现一个问题,无法升级,而且当你重新运行pip的时候会出错

image.png

排除系统变量问题后,又没安装Python2的版本怎么会出现pip失效的情况
,可以使用下面命令修复安装pip

windows平台解决方法

python -m ensurepip
重新引导

然后执行升级命令

python -m pip install --upgrade pip
升级

Linux平台的解决方法

sudo apt-get install python3-pip

然后就可以愉快的使用pip了

参考文档:ensurepip —引导 pip 安装程序

推荐阅读更多精彩内容