Flutter入门——Windows下的安装与环境配置(二)

前言:作为一只刚刚躺完坑的猿、以简书的方式记录这配置的大型入坑现场。

flutter 特点:跨平台,高质量,热更新,更接近原生体验!等......

个人PC

windows 10

core i7 7th

运行内存12g

Flutter的相关连接

1、github地址

2、flutter SDK下载地址

3、中文网

以下是我的Flutter SDK下载的版本

Flutter的sdk

windows 配置环境变量

我把下载好的Flutter SDK放到了我的C盘里面。

在Windows的搜索框里输入   env

进行环境配置

env

双击  Path


配置

把下载好的Flutter SDK里的flutter\bin添加   记得确认

使用镜像

由于在国内访问Flutter有时可能会受到限制,Flutter官方为中国开发者搭建了临时镜像,大家可以将如下环境变量加入到用户环境变量中:

export PUB_HOSTED_URL=https://pub.flutter-io.cn

export FLUTTER_STORAGE_BASE_URL=https://storage.flutter-io.cn


用户变量

注意: 此镜像为临时镜像,并不能保证一直可用,读者可以参考详情请参考 Using Flutter in China 以获得有关镜像服务器的最新动态。

在Android studio里下载 Flutter和Dart插件


install

使用 flutter doctor  进行命令检测

问题

问题:Android工具链——针对Android设备开发(Android SDK版本28.0.3),Android许可状态未知。尝试重新安装或更新您的Android SDK管理器。详细信息请参见https://developer.android.com/studio/#下载或访问https://flutter.dev/setup/#android-setup指令。

然后新建一个Flutter项目 就好啦就好啦!!!!!!~~~

最后效果

总结:

安装大致流程

下载配置flutter sdk,环境变量;

Android studio 安装flutter ,Dart插件;

Android studio 设置 flutter sdk路径;

问题

运行flutter upgrade 时卡很久

大致原因是网络问题,我这边开不开(v)飞(p)机(n)都一样;

解决:根据官方文档,设置两个环境变量;

运行指令flutter doctor提示 Flutter requires Android SDK 28 and the Android BuildTools 28.0.3

解决:打开sdk manager 升级build tool

运行指令flutter doctor提示 X Android license status unknown.

Try re-installing or updating your Android SDK Manager.

解决:升级sdkmanager,命令行运行指令F:\sdk\tools\bin\sdkmanager --update

升级sdk manager 失败

提示:Exception in thread “main” java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema

解决:a,请检查自己的java环境变量;

b,我自己是因为java jdk版本太高(10),换成jdk 8 就行了;

运行指令flutter doctor提示! Some Android licenses not accepted.

解决:运行指令:flutter doctor --android-licenses,根据提示输入y就行;

运行指令flutter doctor提示! No devices available

解决:新建模拟器或连手机;

新建flutter project 的时候卡在 new flutter project 界面

解决:杀了as,检查workspace 内是否有那个项目,如果有直接在as中打开;

如果没有,检查flutter 配置,命令行运行flutter doctor 查看有什么问题;

长时间卡在 Running pub upgrade… 不动了

解决:按一下回车试试,遇到了两三次都这么解决。。

如下图,开始只有红色框中的内容,按一下回车。后面马上打印了一长串内容;


推荐阅读更多精彩内容