关于Cocoapods的安装

后续更新提示:在系统升级到10以后,安装cocoapods的环境要求Xcode8开发工具。而且下面的方法可以实现初步安装,但是会遇到一些问题。

pod setup 遇到错误

➜  ~  pod setup

Setting up CocoaPods master repo

[!] /usr/bin/git clone https://github.com/CocoaPods/Specs.git master

解决办法:

http://www.jianshu.com/p/bd4faaa95770 我这里已经整理。

其他错误可参考链接到 http://www.cocoachina.com/ios/20160922/17622.html

版本10.12系统可参考下面的安装步骤,但是ruby环境,请配置最新的。

Cocoa pods安装

1.检查Ruby 环境

1. CocoaPods需要Ruby环境,OSX自带。但是如果ruby配置不对,安装Cocoapods会麻烦许多。

➜  ~  rvm list

输出结果:(若升级后有多余版本,请删除较低版本)

rvm rubies

=* ruby-2.3.0 [ missing bin/ruby ]

# => - current

# =* - current && default

#  * - default

如果配置环境2.0.0以上不想麻烦就不必升级了。(详情)需要升级可连接  https://rubygems.org/

升级方法:

$ gem update --system

//没反应,用下面的

$ gem install rubygems-update  # again, might need to be admin/root

$ update_rubygems              # ... here too

升级完成回来,继续。(顺利,只需两步)

1. 直接运行命令:

$ sudo gem install cocoapods

苹果系统升级10.11.1   OS X EL Capitan 后改为

$sudo gem install -n /usr/local/bin cocoapods

2. 安装结束的时后,执行命令:

$ pod setup

安装可能遇到的问题:

1. 如果没有反应,可能是https被墙,用以下命令更换域名:

$ gem sources --remove https://rubygems.org/

$  gem sources --add https://ruby.taobao.org/

//要想验证是否替换成功了,可以执行:

$ gem sources -l

//正常的输出是:

*** CURRENT SOURCES ***

http://ruby.taobao.org/

2. gem版本过老 gem是管理Ruby库和程序的标准包,如果它的版本过低也可能导致安装失败,解决方案自然是升级gem,执行下述命令即可:

查看版本 :现在是 2.6.3 版本

$gem --version

升级:

$ sudo gem update --system

3.执行 sudo gem install -n /usr/local/bin cocoapods 报错

ERROR:  While executing gem ... (Gem::DependencyError)      

Unable to resolve dependencies: cocoapods requires cocoapods-core (= 0.33.1), claide (~> 0.6.1), cocoapods-downloader (~> 0.6.1), cocoapods-plugins (~> 0.2.0), cocoapods-try (~> 0.3.0), cocoapods-trunk (~> 0.1.1), nap (~> 0.7)

对于这种错误,最好直接删除当前的ruby,重新配置ruby环境

4. 执行 pod setup 报错:

/Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:298:in `to_specs': Could not find 'cocoapods' (= 0) among 6 total gem(s) (Gem::LoadError) from /Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:309:in `to_spec' from /Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_gem.rb:53:in `gem' from /Users/wangzz/.rvm/rubies/ruby-1.9.3-p448/bin/pod:22:in

这就是路径设置的问题,执行下列命令解决问题:

$ rvm use ruby-1.9.3-p448

解决问题好再按要求重新安装。

检查是否安装成功

$gem list

结果显示:

*** LOCAL GEMS ***

activesupport (4.2.6)

bigdecimal (1.2.7, default: 1.2.0)

claide (0.9.1)

cocoapods (0.39.0)

cocoapods-core (0.39.0)

cocoapods-downloader (0.9.3)

cocoapods-plugins (0.4.2)

cocoapods-search (0.1.0)

cocoapods-stats (0.6.2)

cocoapods-trunk (0.6.4)

cocoapods-try (0.5.1)

colored (1.2)

escape (0.0.4)

fuzzy_match (2.0.4)

i18n (0.7.0)

io-console (0.4.5, default: 0.4.2)

json (1.8.3, default: 1.7.7)

minitest (5.8.4, default: 4.3.2)

molinillo (0.4.4)

nap (1.1.0)

netrc (0.7.8)

power_assert (0.2.7)

psych (2.0.17, default: 2.0.0)

rake (11.1.2, default: 0.9.6)

rdoc (4.2.2, default: 4.0.0)

rubygems-update (2.6.3)

test-unit (3.1.8, default: 2.0.0.0)

thread_safe (0.3.5)

tzinfo (1.2.2)

xcodeproj (0.28.2)

安装成功。

推荐阅读更多精彩内容