阿里云 Centos 7.4 安装 Docker (入门篇)

96
OzanShareing
2018.05.15 10:41* 字数 1218

引言

本文参考:Get Docker CE for CentOS ,参考Docker官网安装说明。

参考资料:

引文

To get started with Docker CE on CentOS, make sure you meet the prerequisites, then install Docker.

OS requirements
To install Docker CE, you need a maintained version of CentOS 7. Archived versions aren’t supported or tested.
The centos-extras repository must be enabled. This repository is enabled by default, but if you have disabled it, you need to re-enable it.
The overlay2 storage driver is recommended.

CE为community社区版,如果想安装docker,需要满足一些先决条件:

目前,CentOS 仅发行版本中的内核支持 Docker。

  • Docker 运行在 CentOS 7 上,要求系统为64位、系统内核版本为 3.10 以上。
  • Docker 运行在 CentOS-6.5 或更高的版本的 CentOS 上,要求系统为64位、系统内核版本为 2.6.32-431 或者更高版本。

使用 yum 安装(CentOS 7下)

Docker 要求 CentOS 系统的内核版本高于 3.10 ,查看本页面的前提条件来验证你的CentOS 版本是否支持 Docker 。
通过 uname -r 命令查看你当前的内核版本

[root@OzanZone ~]# uname -r
3.10.0-693.2.2.el7.x86_64

安装 Docker
Docker 软件包和依赖包已经包含在默认的 CentOS-Extras 软件源里,安装命令如下:

[root@OzanZone ~]# yum -y install docker-io
Loaded plugins: fastestmirror
base                                                             | 3.6 kB  00:00:00     
epel                                                             | 4.7 kB  00:00:00     
extras                                                           | 3.4 kB  00:00:00     
updates                                                          | 3.4 kB  00:00:00     
(1/7): epel/x86_64/group_gz                                      |  84 kB  00:00:00     
(2/7): base/7/x86_64/group_gz                                    | 166 kB  00:00:00     
(3/7): epel/x86_64/updateinfo                                    | 922 kB  00:00:00     
(4/7): updates/7/x86_64/primary_db                               | 1.0 MB  00:00:00     
(5/7): extras/7/x86_64/primary_db                                | 104 kB  00:00:00     
(6/7): base/7/x86_64/primary_db                                  | 5.9 MB  00:00:00     
(7/7): epel/x86_64/primary_db                                    | 6.4 MB  00:00:00     
Determining fastest mirrors
...
Complete!

上一步骤执行完成之后,才意识到一个问题:

为什么网上既有yum install docker,又有yum install docker-io的方式,还有yum install docker-ce及yum install docker-engine。

区别:

  • docker-io 是以前早期的版本,版本号是 1.*,最新版是 1.13
  • docker-ce 是新的版本,分为社区版 docker-ce 和企业版 docker-ee,版本号是 17.* ,最新版是 17.12。

下面我们使用yum install docker-ce的方式来安装docker。

重新安装Docker(使用yum install docker-ce 官方推荐)

1. 如果有,先删除旧版Docker

根据官网的说明,如果CentOS7中有旧版本的Docker,需要先删除,给出了删除命令。
如果之前没装过,结果如下图:

[root@OzanZone ~]# yum remove docker \
>                   docker-client \
>                   docker-client-latest \
>                   docker-common \
>                   docker-latest \
>                   docker-latest-logrotate \
>                   docker-logrotate \
>                   docker-selinux \
>                   docker-engine-selinux \
>                   docker-engine
Loaded plugins: fastestmirror
No Match for argument: docker
No Match for argument: docker-client
No Match for argument: docker-client-latest
No Match for argument: docker-common
No Match for argument: docker-latest
No Match for argument: docker-latest-logrotate
No Match for argument: docker-logrotate
No Match for argument: docker-selinux
No Match for argument: docker-engine-selinux
No Match for argument: docker-engine
No Packages marked for removal

2. 安装Docker Community Edition社区版

官网上说安装Docker之前,推荐先安装Docker's repositories,以方便安装和升级任务。

2.1 先安装repository
2.1.1 安装依赖的包,命令如下
yum install -y yum-utils \
device-mapper-persistent-data \
lvm2
2.1.2 安装repository,命令如下
yum-config-manager \
--add-repo \
https://download.docker.com/linux/centos/docker-ce.repo
2.2 再安装Docker Community Edition
2.2.1 输入如下命令安装最新版的(先看后面的文字,可能要先操作后面的步骤)(在生产环境中应安装指定版本,例如要安装17.09.1版本,则命令为yum install docker-ce-17.09.1.ce-1.el7.centos)
[root@OzanZone ~]# yum install docker-ce
Loaded plugins: fastestmirror
docker-ce-stable                                                 | 2.9 kB  00:00:00     
docker-ce-stable/x86_64/primary_db                               |  13 kB  00:00:01     
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package docker-ce.x86_64 0:18.03.1.ce-1.el7.centos will be installed
--> Processing Dependency: container-selinux >= 2.9 for package: docker-ce-18.03.1.ce-1.el7.centos.x86_64
--> Processing Dependency: pigz for package: docker-ce-18.03.1.ce-1.el7.centos.x86_64
--> Processing Dependency: libltdl.so.7()(64bit) for package: docker-ce-18.03.1.ce-1.el7.centos.x86_64
--> Running transaction check
---> Package container-selinux.noarch 2:2.42-1.gitad8f0f7.el7 will be installed
---> Package libtool-ltdl.x86_64 0:2.4.2-22.el7_3 will be installed
---> Package pigz.x86_64 0:2.3.4-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================
 Package              Arch      Version                       Repository           Size
========================================================================================
Installing:
 docker-ce            x86_64    18.03.1.ce-1.el7.centos       docker-ce-stable     35 M
Installing for dependencies:
 container-selinux    noarch    2:2.42-1.gitad8f0f7.el7       extras               32 k
 libtool-ltdl         x86_64    2.4.2-22.el7_3                base                 49 k
 pigz                 x86_64    2.3.4-1.el7                   epel                 81 k

Transaction Summary
========================================================================================
Install  1 Package (+3 Dependent packages)

Total download size: 35 M
Installed size: 151 M
Is this ok [y/d/N]: y
Downloading packages:
(1/4): container-selinux-2.42-1.gitad8f0f7.el7.noarch.rpm        |  32 kB  00:00:00     
(2/4): libtool-ltdl-2.4.2-22.el7_3.x86_64.rpm                    |  49 kB  00:00:00     
(3/4): pigz-2.3.4-1.el7.x86_64.rpm                               |  81 kB  00:00:00     
warning: /var/cache/yum/x86_64/7/docker-ce-stable/packages/docker-ce-18.03.1.ce-1.el7.centos.x86_64.rpm: Header V4 RSA/SHA512 Signature, key ID 621e9f35: NOKEY
Public key for docker-ce-18.03.1.ce-1.el7.centos.x86_64.rpm is not installed
(4/4): docker-ce-18.03.1.ce-1.el7.centos.x86_64.rpm              |  35 MB  00:00:05     
----------------------------------------------------------------------------------------
Total                                                      5.9 MB/s |  35 MB  00:05     
Retrieving key from https://download.docker.com/linux/centos/gpg
Importing GPG key 0x621E9F35:
 Userid     : "Docker Release (CE rpm) <docker@docker.com>"
 Fingerprint: 060a 61c5 1b55 8a7f 742b 77aa c52f eb6b 621e 9f35
 From       : https://download.docker.com/linux/centos/gpg
Is this ok [y/N]: y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : pigz-2.3.4-1.el7.x86_64                                              1/4 
  Installing : libtool-ltdl-2.4.2-22.el7_3.x86_64                                   2/4 
  Installing : 2:container-selinux-2.42-1.gitad8f0f7.el7.noarch                     3/4 
setsebool:  SELinux is disabled.
  Installing : docker-ce-18.03.1.ce-1.el7.centos.x86_64                             4/4 
  Verifying  : 2:container-selinux-2.42-1.gitad8f0f7.el7.noarch                     1/4 
  Verifying  : libtool-ltdl-2.4.2-22.el7_3.x86_64                                   2/4 
  Verifying  : docker-ce-18.03.1.ce-1.el7.centos.x86_64                             3/4 
  Verifying  : pigz-2.3.4-1.el7.x86_64                                              4/4 

Installed:
  docker-ce.x86_64 0:18.03.1.ce-1.el7.centos                                            

Dependency Installed:
  container-selinux.noarch 2:2.42-1.gitad8f0f7.el7 libtool-ltdl.x86_64 0:2.4.2-22.el7_3
  pigz.x86_64 0:2.3.4-1.el7                       

Complete!

可能会出现的错误:
centos7更新完源之后安装软件会出现这个错误。
实质性问题就是自己系统没有yum的GPG密钥。
从mirrors.163.com这个网址导入自己系统相配的密钥。
输入命令rpm --import http://mirrors.163.com/centos/RPM-GPG-KEY-CentOS-7
再输入yum -y install tree 命令完成。

我安装docker-ce就没有出现这样的问题。

2.2.2 启动docker
systemctl status docker

systemctl start docker
2.2.3 设置docker

输入cd /etc/docker进入此目录,再输入ls查看里面的文件,没有daemon.json文件,那么就自己创建这个文件。

输入touch daemon.json命令创建,再输入vi daemon.json打开文件,按i进入编辑模式,输入下面的json代码,按Esc退出编辑,最后输入:wq保存并退出。

{
"registry-mirrors":["https://xxxxxxxxx.mirror.aliyuncs.com"]
}

上面这个地址可去网上找一个阿里云的镜像提供地址,这样以后下载镜像会快些。
也中以输入cat daemon.json命令再查看一下。
记得用命令systemctl restart docker重启Docker。

接着下载个redis镜像试试


然后运行redis,输命令docker run -d -p 6379:6379 --name redis01 redis

通过docker ps命令来查看正在运行的所有docker容器,来查看是否redis01已成功运行。

然后新开一个终端,输入命令ifconfig来查看CentOS7.4的IP地址,如下图

在阿里云ECS实例中检查防火墙是否开启:

[root@OzanZone docker]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:firewalld(1)

启用防火墙服务(一般默认是开启的)

systemctl start firewalld.service

开启CentOS7.4的6379端口(--permanent表示永久有效,不写则重启系统失效,这里我不写)

firewall-cmd --zone=public --add-port=6379/tcp --permanent

然后可检查一下,如下图

可以在我的Win10系统里用RedisClient工具来连接虚拟机CentOS7.4中的Docker容器中的redis了,如下图

到此,安装与测试结束了~

安装指定版本的Docker

选择版本号:
https://yum.dockerproject.org/repo/main/centos/7/Packages/

网址中列举的都是些docker-io、docker-engine的docker旧版本。直接忽略~~

后端运维
Web note ad 1