适配iOS7的一些坑

自从Xcode8.0之后,默认不适配iOS7了,最低适配是iOS8。但是有的项目还是要适配iOS7,那必须要装Xcode8以前的版本了。在此记录下我适配iOS7的一些坑:
1.错误:***** Assertion failure in -[UITextView layoutSublayersOfLayer:], /SourceCache/UIKit/UIKit-2935.138/UIView.m:8794**
有人说是在iOS7,tableView上不能添加子控件,但实质上不是这个原因。在iOS7添加到tableView上的子控件用的自动布局,但是子控件在tableView上的布局就不能用自动布局,要不就报这个错误

2.错误:*** Assertion failure in -[UITextView layoutSublayersOfLayer:], /SourceCache
在iOS7如果用自动布局,UITextview上不能添加子控件

如果发现新的坑,我会继续添加

推荐阅读更多精彩内容

  • 发现 关注 消息 iOS 第三方库、插件、知名博客总结 作者大灰狼的小绵羊哥哥关注 2017.06.26 09:4...
    肇东周阅读 7,561评论 4 41
  • 今天阴历2016年最后一天,也是玛雅历黄种子日第一天,播种的日子,一定要播种对自己2017年最好的种子哦!我播种了...
    Jocelynwang阅读 31评论 0 0
  • 改革改革
    5a97557ce4be阅读 132评论 2 2
  • 演讲即演说,不仅是一种分享,也是一种对自身沟通能力的提升,演讲的形式多种多样,主要核心是以语言为手段的方式,演讲一...
    家庭教育秦燕阅读 134评论 0 1