Mac下升级php版本并配置

Mac(OS X EI Capitan 10.11.6)上自带了php,但是版本比较老(5.5.**),适合学习使用。现需要升级PHP版本到5.6.**,操作如下:

1.安装php

输入命令:

curl -s http://php-osx.liip.ch/install.sh | bash -s 5.6

2.修改PATH

输入命令:

export PATH=/usr/local/php5/bin:$PATH

PATH根据具体下载后放置的路径进行修改

3.查看php版本

输入命令:

php -v

这是应该能看到php版本已经是所安装的版本

4.但是如果需要使用安装的php版本开发还需要如下操作:

vi /etc/apache2/httpd.conf

把LoadModule php5_module libexec/apache2/libphp5.so这一行用#注释掉,并添加类似如下一行:

LoadModule php5_module /usr/local/php5-5.6.23-20160626-132038/libphp5.so

如果使用brew安装,应该类似为:

LoadModule php5_module /usr/local/Cellar/php56/5.6.11_2/libexec/apache2/libphp5.so

可以通过:

mdfind -name "libphp5"

来查找libphp5.so的路径

5.最后重启Apache

sudo apachectl restart

推荐阅读更多精彩内容