centos6.9安装xampp后报错:egrep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

1、centos6.9安装xampp(xampp-linux-x64-7.0.21-0-installer.run)后启动的时候,报错:

egrep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

egrep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

/bin/bash: error while loading shared libraries: libdl.so.2: cannot open shared object file: No such file or directory

egrep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

start

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

startapache

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

startmysql

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

startftp

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

stop

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

stopapache

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

stopmysql

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

stopftp

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

reload

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

reloadapache

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

reloadmysql

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

reloadftp

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

restart

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

security

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

enablessl

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

disablessl

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

backup

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

oci8

egrep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

/opt/lampp/bin/gettext: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

panel

egrep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

2、有人说少了glibc包,32/64的都安装了,然并卵

[admin@19-56 lampp]$ yum list glibc

Loaded plugins: fastestmirror

Determining fastest mirrors

base                                                                                                                                                                                 | 3.7 kB     00:00

epel                                                                                                                                                                                 | 4.3 kB     00:00

extras                                                                                                                                                                               | 3.4 kB     00:00

jenkins                                                                                                                                                                              | 2.9 kB     00:00

jenkins/primary_db                                                                                                                                                                   |  99 kB     00:23

updates                                                                                                                                                                              | 3.4 kB     00:00

updates/primary_db                                                                                                                                                                   | 2.5 MB     00:00

zabbix                                                                                                                                                                               |  951 B     00:00

zabbix/primary                                                                                                                                                                       | 8.4 kB     00:00

zabbix                                                                                                                                                                                                57/57

zabbix-non-supported                                                                                                                                                                 |  951 B     00:00

Installed Packages

glibc.x86_64                                                                                   2.12-1.209.el6_9.1                                                                                   @updates

Available Packages

glibc.i686                                                                                     2.12-1.209.el6_9.2                                                                                   updates

glibc.x86_64                                                                                   2.12-1.209.el6_9.2                                                                                   updates

[admin@19-56 lampp]$ ./xampp

3、千辛万苦还是找到了答案:

vi /opt/lampp/lampp

找到export LD_ASSUME_KERNEL=2.2.5这一行,

并修改内容为export LD_ASSUME_KERNEL=2.8.0,保存退出就可以解决了。

当然修改为不低于2.6.32的其他值也可以,比如2.6.32

Linux  内核版本



4、找了下这个设置的资料解释,原来这个配置是为了旧操作系统的一些兼容性问题

LD_ASSUME_KERNEL

What is LD_ASSUME_KERNEL all about?

The environment variableLD_ASSUME_KERNELcan be set to a value that indicates the kernel OS API version an application is compatible with and is used by the Linux Dynamic Linker/Loader for determining what directory paths to use when loading the Standard C Library (GLIBC or libc.so.6). This is the primary mechanism for dealing with backwards compatibility for applications written for older Linux versions.

Here are the directory paths that are chosen based on the setting of LD_ASSUME_KERNEL:

/lib/libc.so.6

/lib/i686/libc.so.6

/lib/tls/libc.so.6

One of the primary distinguishers of features is the difference between the olderLinuxThreadsPOSIX threading model and the newer threading modelNPTL(Native POSIX Thread Library). This can be determined as follows on a Linux BASH command line;

developer@linux:~> /lib/libc.so.6

GNU C Library stable release version 2.3.5 (20050802), by Roland McGrath et al.

Copyright (C) 2005 Free Software Foundation, Inc.

This is free software; see the source for copying conditions.

There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A

PARTICULAR PURPOSE.

Configured for i686-suse-linux.

Compiled by GNU CC version 4.0.2 20050901 (prerelease) (SUSE Linux).

Compiled on a Linux 2.6.12 system on 2005-09-09.

Available extensions:

GNU libio by Per Bothner

crypt add-on version 2.1 by Michael Glad and others

linuxthreads-0.10 by Xavier Leroy

GNU Libidn by Simon Josefsson

NoVersion patch for broken glibc 2.0 binaries

BIND-8.2.3-T5B

libthread_db work sponsored by Alpha Processor Inc

NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk

Thread-local storage support included.

For bug reporting instructions, please see:

.

developer@linux:~>

developer@linux:~> /lib/tls/libc.so.6

GNU C Library stable release version 2.3.5 (20050802), by Roland McGrath et al.

Copyright (C) 2005 Free Software Foundation, Inc.

This is free software; see the source for copying conditions.

There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A

PARTICULAR PURPOSE.

Configured for i686-suse-linux.

Compiled by GNU CC version 4.0.2 20050901 (prerelease) (SUSE Linux).

Compiled on a Linux 2.6.12 system on 2005-09-09.

Available extensions:

GNU libio by Per Bothner

crypt add-on version 2.1 by Michael Glad and others

Native POSIX Threads Library by Ulrich Drepper et al

GNU Libidn by Simon Josefsson

NoVersion patch for broken glibc 2.0 binaries

BIND-8.2.3-T5B

NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk

Thread-local storage support included.

For bug reporting instructions, please see:

.

developer@linux:~>

(Note: This example is on SLES 9. SLES 10 has deprecated support for Linux Threads and only supports NPTL)

参考:1、http://gaodi2002.blog.51cto.com/5940761/1942697

2、https://www.novell.com/developer/ld_assume_kernel.html

推荐阅读更多精彩内容